5138 comments

Hello guys, are you going to update react-router from 3 to 4 version in react project?
Hi, yes, currently we are a bit delayed with the release of next version but for sure we will be updating to latest version of the react-router.

Thanks
Regards
Hi,
I downloaded Angle Bootstrap admin using angular 4, i am trying to use model popup for other pages but its not working properly. Model Popup showing under background, model-backdrop loading first and also notification folder working properly can you explain me how to do that for other pages also..
Hi, please try the following approach, this solution was reported by another user but recently we have tested it and it seems to be working fine:

1- Edit file src/app/shared/styles/app/animate.scss
2- Change the css used for animation to the following, note that the "not" selector was removed and it has different rules for animation:

app-layout router-outlet + * {
display: block;
-webkit-animation-duration: 1s;
animation-duration: 1s;
-webkit-animation-fill-mode: backwards;
animation-fill-mode: backwards;
@extend .fadeIn;
}

3- Save and reload the page.

We will include this fix in the following release. Apologies for the inconvenience.

Let us know if you have any question
Regards
Hi,
Its working fine now, Thanks for the solution.
Hey i have done proper installation while i am staring ng serve
getting many times
Flowing issue
ERROR in multi script-loader!./~/jquery/dist/jquery.js script-loader!./src/app/core/preloader/preloader.js script-loader!./~/flot/jquery.flot.js script-loader!./~/jquery.flot.tooltip/js/jquery.flot.tooltip.js script-loader!./~/flot/jquery.flot.resize.js script-loader!./~/flot/jquery.flot.pie.js script-loader!./~/flot/jquery.flot.time.js script-loader!./~/flot/jquery.flot.categories.js script-loader!./~/jquery.flot.spline/jquery.flot.spline.js script-loader!./~/jquery-sparkline/jquery.sparkline.js script-loader!./~/easy-pie-chart/dist/easypiechart.js script-loader!./~/chart.js/dist/Chart.bundle.js script-loader!./~/jqcloud2/dist/jqcloud.js script-loader!./~/bootstrap/js/modal.js script-loader!./~/bootstrap/js/dropdown.js script-loader!./~/bootstrap/js/tooltip.js script-loader!./~/summernote/dist/summernote.js script-loader!./~/moment/min/moment-with-locales.min.js script-loader!./~/fullcalendar/dist/fullcalendar.js
Module not found: Error: Can't resolve '/home/bitlasoft/Documents/indrajeet/newS/ng2/angular2/ng2angle/node_modules/flot/jquery.flot.js' in '/home/bitlasoft/Documents/indrajeet/newS/ng2/angular2/ng2angle'
@ multi script-loader!./~/jquery/dist/jquery.js script-loader!./src/app/core/preloader/preloader.js script-loader!./~/flot/jquery.flot.js script-loader!./~/jquery.flot.tooltip/js/jquery.flot.tooltip.js script-loader!./~/flot/jquery.flot.resize.js script-loader!./~/flot/jquery.flot.pie.js script-loader!./~/flot/jquery.flot.time.js script-loader!./~/flot/jquery.flot.categories.js script-loader!./~/jquery.flot.spline/jquery.flot.spline.js script-loader!./~/jquery-sparkline/jquery.sparkline.js script-loader!./~/easy-pie-chart/dist/easypiechart.js script-loader!./~/chart.js/dist/Chart.bundle.js script-loader!./~/jqcloud2/dist/jqcloud.js script-loader!./~/bootstrap/js/modal.js script-loader!./~/bootstrap/js/dropdown.js script-loader!./~/bootstrap/js/tooltip.js script-loader!./~/summernote/dist/summernote.js script-loader!./~/moment/min/moment-with-locales.min.js script-loader!./~/fullcalendar/dist/fullcalendar.js

Also i install any New npm package always asking same issue how i can fix this unable to install and also new library

Can you guys Update if any fix and new release add Date picker with popups and modal (Issue back drop and css not working)

Update me ASPS urgent request
Hello, the message "ERROR in multi script-loader" is related to how Flot plugin is installed when using npm@5. Using Napa (a tool already included in the template) is possible to install the problematic plugin using npm@5 without errors.
Please follow this instructions:

- Open package.json, and search for an entry named "napa"; add there the following line:

"flot": "flot/flot#v0.8.3"

- Then, remove any other reference to "flot" from entry "dependencies"

- Run npm install enhanced-resolve --save

- Run "npm install" again (it might be necessary to remove node_modules folder first)

Let us know if you have any question
Regards
I can not resolved this issue after to do that. We still have this issue
Hi, we have solved this issue with the same steps described above, only case where it didn't worked was when we haven't deleted the node_modules folder before re-install npm dependencies, have you tried this?
alatty PURCHASED
I've been trying to build the angular2-seed with "ng build --prod --no-sourcemap --aot" but the --aot flag is causing the error message below. I've noticed from other posts that the reason is that some of the 3rd party add-ins are not aot compliant. Is this still the case and if so is there a resolution date. Failing that which modules can be removed so it builds with the -aot flag.

So if I've missed other posts on this issue. Any help is much appreciated.

Thanks

ERROR in ./src/main.ts
Module not found: Error: Can't resolve './$$_gendir/app/app.module.ngfactory' in 'C:\Dev\Angle\angular2-seed\ng2angle\src'
@ ./src/main.ts 4:0-74
@ multi ./src/main.ts
Hi, aot should be supported at least with the modules/plugins provided, meaning if you haven't added any change to the code it should, but in case you have added any third party plugin or changed a version please let us know and we will check a solution for that.

Just in case, a similar issue was found recently with newer versions of angular 4.x, if this is the case please try the following:
- Run npm install enhanced-resolve@3.3.0 --save
- Compile the project again

Regards
Hello,

Using angular/netcore project I tried recently to upgrade from angular 4.0 -> 4.3. I received a bunch of errors when trying to run again, main one being 'Cannot find name "require"' in all the files that use that in the component description. Also had issues finding types for: codemirror, jquery, lodash, moment, node. I rolled back and dont have an npm log of the update, but do you have a better strategy for upgrading @angular packages. And do you know if anything could have changes in the webpack or tsconfig configurations?
Hi, we have tested the project with Angular 4.3.2 and it seems to be working fine.
Just in case, we are using npm@5.3, which triggers an error with Flot chart and can be solved with the following change:

In package.json, find an entry named "napa"; add there the following line:
"flot": "flot/flot#v0.8.3"
Then remove any other reference to "flot" from entry "dependencies".
Before run install again, remove the node_modules entirely, and run "npm cache clean"

We can confirm it works using the project as is distributed, in case you have added or changed any other dependency please let us know and we will check the possible cause.
The project has been tested running the compilation with "npm run compile-app" and from VS2015

Let us know if you have any question
Regards
I migrated my project to vs2017 a while ago. I know this isn't recommended but I did it to use some Entity Framework Core scaffolding tools that weren't working in vs2015. The migration brought back all the associated '.js' and '.js.map' files but everything was compiling and running fine so I just kept it.

Im assuming this is the reason for the breaking changes when I tried 4.0 -> 4.3...

Would you have a set of changes on hand for vs2017 migration or recommend reverting back?
Actually seems the '.js' and '.js.map' files are generated each compile and I noticed this isn't the case in the vs2015 version. Do you know what I would have to change to have the compile process be the same and not generate the extra files?
Found a related stack overflow question: https://stackoverflow.com/questions/42730030/visual-studio-2017-and-webpack-issue. I will probably try this before anything, as don't really want to mess with commit history and trying to roll back unless abs necessary...
Hi, we haven't started the migration to VS2017 yet, we are delayed with the release of the next update but we expect to have it ready soon. Anyway, it should work so you should not need to rollback to VS2015.
In the last post you mentioned a solution from SO which is already applied to the VS2015 project, we have been dealing with that also, we are talking about the config:
<TypeScriptCompileBlocked>true</TypeScriptCompileBlocked>
Please let us know if that solved your issue.
Also, check that your typescript version is 2.2.2, other version might result in a different behavior.
Btw, the error is always "Cannot find name "require"'" ?

Regards
I added the '<TypeScriptCompileBlocked>' tags and deleted all the '.js' and '.js.map' files, built and ran successfully (w/o further generation of the files). I tried the upgrade to angular 4.3 again but same result with the 'Cannot find name "require"..'.

I think though that the 'npm install' snippet I used included a typescript@latest which is 2.4.6. So maybe if I leave typescript at 2.2.2 it may be different result..
Usually the error 'Cannot find name "require"..'.is related with missing node types, although it is not clear what is the relation in this case.
You can try adding (if not yet) the following "types" entry into the tsconfig.json:

{
..
"compilerOptions": {
...
"types": ["node"]
},

And check you have installed in package.json, "@types/node": "6.0.60",
Not sure if the version used here should correlate with the version installed on the system (just in case)

Regards
Tulio PURCHASED
Hi

how is the better way to call one modal in a PartialView.?

The section BodyArea cannot run in a PartialView and the modal cannot show

I currently use the mvc5 + jquery project.

Tx
Hi, here you can find a description of the correct approach in this case and alternative solution (not directly related with modals): https://stackoverflow.com/a/7556594/1754325
For example (without knowing your code) if you try to add a modal into the partial view "_Offsidebar" you will find this file is used in "_Layout.hmlt", so in this case, "_Layout.hmlt" should declare the content of the modal, not the partial.
Btw, the BodyArea section was added to simplify the creation of modals, as long as you add the markup of modals as a child of the <body> tag, there should be no problems.

Regards
Hello,

sorry, I am new here and can't find info... Is this template fully ported to Angular4?
If not, what are your estimates on the date?

Thank you,
Andrej
Hello Andrej, the template is already based on Angular 4 with @angular/cli build tool.
Exact versions: @angular/cli 1.0.0 and Angular 4.0.2 (with lazyLoad and AOT support)
Next version will include updates to latest 4.x (as far as we know there should not be breaking changes)

Let us know if you have any question
Regards
for the AngleUI theme is there a way to pass in values to the sparkline charts? We have tried several ways to do so but the charts do not display unless we hardcode the values into the element in the HTML.

this is using Angular 2/4

the only way it works is if we do

<div class="pv-lg" [sparkline]="sparkOptions2" values="1,3,4,7,5,9,4,4,7,5,9,6,4"></div>

we have tried adding the values as an array onto the front of sparkOptions2
sparkOptions2 = [
"1,3,4,7,5,9,4,4,7,5,9,6,4", // tried this as array and string
{
type: 'line',
height: 80,
width: '100%',
lineWidth: 2,
lineColor: this.colors.byName('purple'),
spotColor: '#888',
minSpotColor: this.colors.byName('purple'),
maxSpotColor: this.colors.byName('purple'),
fillColor: '',
highlightLineColor: '#fff',
spotRadius: 3,
resize: true
};
]

doing our element like so
<div class="pv-lg" [sparkline]="sparkOptions2" [values]="sparkValues"></div>
where sparkValues = '1,3,4,7,5,9,4,4,7,5,9,6,4'

and doing it like
<div class="pv-lg" [sparkline]="sparkOptions2" >{{sparkValues}}</div>
where sparkValues = '1,3,4,7,5,9,4,4,7,5,9,6,4'

we are missing something somewhere, just not sure where.
Hi, sorry for the long delay. Currently the directive only supports html notation for values, i.e, using the comma-separated string in attribute values.
We can send you a modified directive with support for data bind from components, if you are interested please send us a message via our profile and we will send you the file.

Regards
Hi,
I am Using Angular 4 Angle, i want to use datepicker for my project. In interaction folder there was a inline datepicker, but i need a datepicker within textbox(once click the textbox date picker will pop out like that). please help me on that...
Hi, currently we are using datepicker from ngx-bootstrap project, and it doesn't support yet the popup option. Anyway, you could give a try to ng2-datepicker: http://ng2-datepicker.jankuri.com/
Haven't tried yet but it seems to support Angular4 based on their repo information.

Here is another more promising but also very new, and sometimes this may arise some problems in early stage of development: https://github.com/rd-dev-ukraine/angular-io-datepicker

Let us know if you have any question
Regards
nazirsj PURCHASED
Hi, is there letter icon support in this template?
Hi, do yo mean something like an envelope icon?
The template uses font awesome which has the following icon: http://fontawesome.io/icon/envelope/

If you click on the right top bell icon of the header, you will see a dropdown, in that dropdown, one of the items is using the mentioned envelope icon.

Regards
Hi.

I would like to request a new class, namely something like .aside-collapsed-text-sm which collapses the menu to collapsed text only for tablets. I tried implementing it myself but it interferred a bit too much with the original stylesheets to be practically possible with updated later on.

Is this possible to add in a future release? It would be greatly appreciated.
Hi, thanks for the suggestion. We will check of possible to add something like this.
In the meantime, have you tried a solution using JS? for example checking window width on page load and apply the class to body when the site is within the range of tablet resolutions.
We consider this a better solution because the collapsed state is a bit hard to be removed outside the general behavior of the layout in order to make it class-responsive.

Let us know if you have any question or need assistance to implement this
Regards
Yes, I have implemented it in the app component using matchMedia, see pastebin for reference.
https://pastebin.com/ufFXcZhW
Hi, that's a really nice implementation. We could consider something like that for some of the future release.

Thanks for sharing
Let us know if you have any question

Regards
Hey,

I'm trying to setup eslint with the airbnb-style guide. It throws 53270 problems (51825 errors, 1445 warnings). What ruleset are you using in your development process?

Kind regards,
Paul
Hi, depending on the project we have added custom jshint rule-set some time ago, they now become a bit old and eslint has some better features. Anyway, the airbnb style guide was never tested.
We will consider for the next major release to make code compatible with a more robust style guide like you mentioned.

Let us know if you have any question
Regards
candoa PURCHASED
The react version don't work. I run npm install and then nmp start and it won't compile.
Hi, could you post command log? Also what node/npm versions are you using?

Thanks
Regards
Hi, my company want to buy this theme.

I checked your documentation and find out that you use jade as a template engine. But our application is made on plain HTML with Bootstrap and AngularJS 1.

My question is, can I use plain HTML or I have to use jade?

Thanks.
Hi, you can use raw HTML, we suggest to use JADE and LESS or SCSS because the code is more simple and has many advantages over classic languages but since those files are compiled into html, css and js, you can use the compiled version instead.

Let us know if you have any question
Regards
Is there any chance you will be adding user management like the one from MEAN to angular 4 version anytime soon?
Hi, we will consider that but for the moment is not a priority, mainly because the user management requires a server side implementation and that becomes a feature that is more particular of the application requirements and our template are focused mainly on frontend features.

Let us know if you have any question
Regards
Western PURCHASED
Hi, I've been struggling trying to replicate the new Angular-Material form that's in the Material-seed but using the backend-meteor-angular-seed.

Basically I need to use a Angular-Material Form but using Meteor.
Can you help?
Thanks
Hi, do you need only the angular material forms with the classic "Angle" styles, or do you want to implement the complete material version into the meteor+angular project? (always talking about seed versions)

Regards
Western PURCHASED
Thanks again for the quick reply. I just need the angular material forms so I can enable functionality such as Fab speed dials.
Hi, the Fab speed dials belongs to the angular-material framework so we can send the backend-meteor-angular-see with the angular (1.x) material framework implemented and a demo view. If you are interested please send us a message via our profile so we can send you the files via email.
This will be more simple than describing the full instructions.

Regards
Good afternoon
I am José Machado @jmminformatica
I bought the item with Order ID: WB0230BP6. My question is as follows, how do I just use the html5 version with javascript or bought it wrong? I do not intend to use MVC and I was confused. Please help me
Please reply to suporte@jmminformatica.pt
Hi, the mentioned item WB0230BP6 doesn't correspond to any of our products. You should contact the author of the item, you can find such information in the item description page.

Regards
Hi,
I bought the item with Order ID: WB04HF123.
How do I use fontawesome icons in the template for angular 4?
As long I can see it's using glyphicon, If I need to change the menu icons for fontawesome it's not clear for me how to do it.

Menu.ts
const Home = {
text: 'Home',
link: '/home',
icon: 'icon-home'
};
Hi, the template uses FontAwesome and SimpleLineIcons as default icon fonts, Glyphicons is disabled by default. To change to FA, just add the class name you want to use in the "icon" entry of the menu definition:
Like this:

const Home = {
text: 'Home',
link: '/home',
icon: 'fa fa-star'
};

Regards
abaalkh PURCHASED
Hi,

What's the best way to install this theme on Laravel 5.4?
It doesnt use gulp anymore or has angular.

Regards
Hi, you can integrate the jQuery version of the project with Laravel. We don't have instructions step by step but the idea is basically to create an "empty" Laravel project as they indicate in the docs and then go adding pages, files, assets, into the framework. It's not a very easy task but it should not be a panic if you use the jQuery version that has the more "classic" structure.
Regarding to build tool, Laravel 3.4 moved from gulp to Wepack we are not supporting that for the moment, we plan to add webpack as build tool in the future but no ETA for the moment. In case of you using Angularjs, the most simple option to integrate with Laravel is to use it as an api server and then use the feature from angular that facilitates the communication with the server. This way you don't require to integrate angular code into laravel structure.

Hope this helps,
Regards
ruwadt PURCHASED
Hello Support,

I just purchased the theme and I have one question. How to set RTL layout as default layout.
I am using jquery version.

Thanks
Mohammad
Hi, the RTL version is based mainly on stylesheet, the files app-rtl.css and bootstrap-rtl.css are automatically generated (when using gulp) with the same styles but inverted for RTL layout., so if you include this files by in your pages, the RTL layout will be the default.

Let us know if you have any question
Regards

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
11055Purchases

Licenses: Details »

Single application $24
Version:3.8.2
Type:
  • HTML Template
Bootstrap: Compatible with 3.3.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 9, 10, 11
  • Latest Chrome
  • Latest Edge
  • Latest Firefox
  • Latest Safari
Uses Less:Yes
Uses Sass:Yes
Categories:
Tags: admin, admin template, angularjs, material, meanjs, meteor, mvc, rails, responsive, rtl
Item#:WB04HF123
Released:3 years ago
Updated:1 week ago
Sold exclusively on WrapBootstrap
themicon

themicon

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: