5315 comments

sunil233 PURCHASED
Hi iam planning to buy Angle - Bootstrap Admin Template with angular 5 + CLI
I want to integrate on top of Asp.net application.Some pages are in angular and some pages are in aspx with out angular.Is it possible to integrate angular 5 + CLI in our application with out issues?
Hi, the version we have for netcore and angular5 is not using @angular/cli, we found some solutions but none of them works out of the box like using a custom webpack setup. Anyway, our project uses webpack to process all files from angular and aspx is only used to load the initial page that allow angular app to start. So, in other words, the project has only a HomeController that uses a layout to load the main files generated from webapck and contains the basic markup for the application, beyond that point, angular takes controls and aspx is no more used.

Another important is that the template was designed to build your application on top of it and not to integrate with another application, meaning, if you have separated components already created you can try to add them to the existing structure of the template with routes, views, etc. But if your application relies on an existing layout and structure, it's necessary to adapt it the structure of the template, otherwise you won't be able to compile the files correctly.

Regards
sunil233 PURCHASED
Hi will there be any support for the purchase and if any updates on the versions are supported?
HI ,support and updates are included as part of the purchase.
We provide support for issues or bugs related with the product.

Let us know if you have any question
Regards
Hi,
I'm using Angle AngularJS template with order ID #WB088DN21. When I am loading datatables with large dataset , rendering becomes very slow (for 7000 watchers it takes around 7 seconds to render). While rendering same data with standalone angular application is very fast. Please help me with this issue.
Hi, it's hard to say where could be the issue but have you tried using the seed project to run the same code with datatable?. Comparing against a standalone angular application is not a simple way to test performance because of the extra features involved into the template may a affect performance for such a big processed data array. With AngularJS do you mean 1.x or v5?
For example, in Angular 1.x for DataTableController we use only the code to invoke the third party plugin but we don't perform any extra action to affect the processing of the information.

Regards
claymon PURCHASED
We are using the Angle-Angular 5-netcore template. For some reason we cannot get breakpoints to work in the ts files when debugging. Any thoughts on what we might do to make that happen? Thanks!
Hi, the TS files are managed and compiled by webpack, that's why you need to use the browser to debug them because VS doesn't have track on the processing of that files. We don't know a way to do that from Vs, but you can use chrome dev tools to access ts files from source navigator and then work with breakpoints directly in the browser.

Regards
claymon PURCHASED
ok but it is interesting to note that the VS 2017 Angular Template does somehow allow for setting breakpoints. Could it be related to how webpack in the Angle Template creates the js files and source maps?
Originally we created this project based on the template provided here https://github.com/aspnet/JavaScriptServices
Which is more focused on using webpack sourcemaps and debugging in the browser than from VS, that could be the difference with the VS 2017 Angular Template you mention.
For the moment this is how it works, we will investigate further details to see if possible to add some package that allows debugging from VS.

Thanks
Regards
claymon PURCHASED
Ok. Thanks for the help! Most appreciated!
claymon PURCHASED
I just got this working. I noted the post https://www.ryadel.com/en/visual-studio-2017-breakpoint-not-working-net-core-2-angular-typescript-webpack/ . From that post I discerned that to break into a constructor you may need to leave the component and come back to it so the debugger can attach. Works now. Thanks!
Thanks so much claymon for pointing us this.
We will give it a try and perform changes to provide this feature.

Thanks again!
Regards
How to separate 2 or more sections in menu like in
Angular 5 + CLI(http://themicon.co/theme/angle/v3.8.3/angular5/) Menu is divided into 3 sections namely
Main Navigation, Components, More which are just headings

I've MeanJS Template(Angular 5 + CLI(http://themicon.co/theme/angle/v3.8.3/angular5/)) how to achieve sections in menu like in this Angular 5 + CLI(http://themicon.co/theme/angle/v3.8.3/angular5/)
Hi, sorry for the long delay.
Currently the MeanJS project doesn't support item heading in the sidebar but with a few modifications to the sidebar markup is possible to achieve the same result. If you are interested please send us a message via our profile page and we will send you via email the modified files and example code to add headings to sidebar.

Let us know if you have any question.
Regards
profile page as in? from where i should send the message
sure i'll send message via profile page
Already sent a message to user sanketk99 with the file

Thanks
Regards
alexganz PURCHASED
I'm using the jQuery version.

Position:Fixed CSS for elements does not work when I use a fixed layout? Can you help?
Hi, usually issues with fixed elements are related with z-index, have you tried using a high value for the element?
If it doesn't work, it could be some kind of conflict with the layout or something we haven't considered. in this case please let us know more details about what you are trying to achieve and if you can share code that would be better.
If you want to keep it private, please send us a message via our profile and we will chat via email.

Regards
usamaxyz PURCHASED
Thank you for your efforts. 1. In horizontal layout: sub nav bar looks strange (muli level menu). 2. In both layouts, in nav bar, i tried to put text instead of logo image but it looks strage too.
I wish you fix them in the next update.
Thanks.
Hi, thanks for your feedback.
1- You are right, but please consider that bootstrap 3 doesn't support more than one nested dropdown menu level as it is stated here: https://stackoverflow.com/a/18024991/1754325
2- In this case, only text is not supported, meaning, there's no special treatment for it. Using text in the logo area is a bit more particular of the project, because of the font used, size, color, etc.
Anyway, it is possible to achieve a similar result using the following css and replacing the <img> markup with a span element like this:
<span>Angle</span>
And css,
.brand-logo > span {
display: block;
line-height: 34px; /* vertical center */
color: #fff;
}

Please let us know if you have any question

Thanks!
Regards
Hello,

does angle support bootstrap 4? If not, do you work on it?
best regards
Hello, we have started to play with it but nothing to deliver yet. We want to wait for an RC at least to start integrating into the project, also we are evaluating the chance to move to webpack and npm (bs4 dropped bower support) which may require a change in the structure of the project. We are considering this mainly because Bootstrap 4 is not backwards compatible.
We expect an RC in the short time because the BS4 project has been moved recently to beta.3

Thanks
Regards
Our apologies, Bootstrap 4 is stable now (released 4 days ago). No RC as it was planned.
We'll try to update soon as possible.
Hi.

Where can i find some guidelines for how to set up the project? I ran 'npm install' inside the angular5-feed project, bug I get some nasty errors.

Thanks.
Hi, it sounds like an issue with versions.
Please check you are using @angular/cli 1.6.1 with node 6+ and npm 5.6.0
If this is not the case please post your log and we will check it. If it's too large, you can use a service like pastebin.com

Regards
Hi I'm using Angular 2 + CLI theme i want my application to use Lodash Version 3.x but a component in Angular 2 + CLI theme called "angular-tree-component" uses Lodash Version 4.x
i tried different ways of installing two different versions of lodash but no luck can you suggest me what i can do
Hi, unfortunately it doesn't seems to be possible to have two or more different versions of a dependency. We have checked the "angular-tree" repo and they are using lodash 4.x since the first release so it could be hard to force that module to use a previous version. Of course, an option is to remove the "angular-tree-component" if you don't nee it.
As an alternative (not tested) there's a plugin that could allow to install another version into a different path, you can check it here: https://github.com/scott113341/npm-install-version
The only cons found is that is doesn't seem to support the save of a dependency.

Regards
dcardoso PURCHASED
Hi there! I just found an annoying bug on the Routes.jsx file. The tags TransitionGroup/CSSTransition causes the components of my application to be loaded twice. The solution was to add the location on the switch (<Switch location={location}>) and exit={false} to the CSSTransition tag.
Check the issue on github: https://github.com/reactjs/react-transition-group/issues/79

Hope this could help people with the same problem and you can patch it on a latter version.
HI, thank you so much for pointing us this issue and most important the solution. We will check this for next update.

Thanks again.
Regards
I purchased this template 6 months ago and have still to get it deployed. Support is horrendous. Buyer beware!!
We really sorry to read this. After check your user found you were asking for some implementation on c9 and digitalocean and unfortunately we don't provide that kind of support. Our products are deployed for each release and can be seen online, they are compiled and working and we release always the same code we use for release. Unfortunately we can't deploy on all platforms but as mentioned, we can confirm all projects works and of course, for some platform they may require some adjustement particular of the platform used. Most of the projects are deployed on apache based servers, but other like rails are on heroku and meteor on diigital ocean.
Please feel free to request a refund if the product doesn't fit your requirements.

Regards
It wasn't just C9/Digital ocean. It was AWS and Heroku too. It was Rails, React and Angular. Every attempt failed and there were many. Last time I wrote support was well over a week ago after trying to get RoR operational on Heroku and still haven't heard back... I've finally give up! Win some lose some.
Hi,

Do you provide a free lite version, so we can have a try?
Hi, no sorry, due to nature of digital goods we are not able to provide a trial version of our products.

Let us know if you have any question
Regards
Which React and React Router versions are used here?
Is jQuery used in React template?
Hi, the project is based on React 15.6.1 and react-router v4
Some plugins are React native but others are based on jQuery which in this case uses .js to run the code and import from the .jsx of the component. Of course, we don't like component wrappers but there wasn't many alternatives to some plugins for React projects.
With the arrive of React 16 we started to refactor some of those points (but not ready yet) and we would like to incorporate in a coming release soon.

Thanks
Regards
Hi .. I am planning to buy this template to use the React version of it
I want to know if it support RTL or not?
Hi, it does support RTL but not a live switch as you can see in other versions of this template. This mainly because we use a custom webpack loader that once enabled will convert styles into RTL using rtlcss package.
In case you want to see it running first, please let us know and we will prepare a demo.

Thanks
Regards
Hi,

I've purchased this template a few days ago, but when I try to start the netcore-angular project all my bower dependencies doesn't get loaded/installed.

I already installed all the node, git, gulp and bower latest versions, but it still doesn't work.

Here is the message I get:

bower flot#0.8.3 MODULE_NOT_FOUND Cannot find module 'bower-npm-resolver'

Any help?
Hi, bower-npm-resolver is installed via npm, and used by bower. Usually this error happens because you need to run "npm install" and then "bower install" so bower can find that module while installing deps.

Let us know if you have any question
Regards
How to run the react based theme?
Hi, the react project can be executed with the following commands:

1- Install depds
> npm install
2- Run project
> npm run start

The last command should open the application in the browser automatically.
For node 8.x, it's necessary to upgrade node-sass to 4.7.2 (see package.json)

In case problems persists, you can try removing node_modules folder and file package-lock.json and then install again.

Regards
nowickim PURCHASED
With the .NET Core + Angular template, what is the suggested way to customize the header color and other defaults within "settings" so that I can apply future changes without having to modify your template? Is there some recommended place to set those? I want the red header and I want the sidebar to float, and then I want to remove the user's ability to change those settings.

Awesome theme by the way, and I especially appreciate the work that went in to the .NET core/Angular setup!
Hi, is possible to save the current settings to localStorage and then restore back when the application is loaded. Meaning, the code with contain the default settings and if there's an entry in the localStorage they will override.
In case you don't want to allow change settings, just put them in the code and they won't change if you remove the right sidebar (offsidebar) that has the UI to change settings. For example, in angular5 version, settings are defined in file src/app/core/settings/settings.service.ts whatever you touch there will affect statically the application.
Themes works similar, in file src/app/core/themes/themes.service.ts you have the list of theme that are available, In that place you can also set a "defaultTheme" variable that will load a specific theme the first time the site is loaded.
Another option for themes is to @import into the main application styles so a specific theme becomes part of the final stylesheet without need of JS to load a stylesheet. You can do this last in file src/app/shared/styles/app.scss by adding at the end @import "themes/theme-a.scss"; or any other files you want.

Thanks for your feedback, much appreciated!
Regards
its says that this template also have netcore 2.0 sample, is it meant to say asp.net core 2.0
Hi, that's right, properly said is ASP.NET Core
Did you asked looking for a specific difference that we may have missing? Our projects were implemented originally in mvc5 and then mvc6 was renamed to .netcore, here is some info about it http://www.hanselman.com/blog/ASPNET5IsDeadIntroducingASPNETCore10AndNETCore10.aspx

Regards
sunil233 PURCHASED
H...can I use the single/multiple licesense version in corporate companies for their clients
.example ...1)iam working in company A and building a project "test" for client "abc"...
can I use or integrate the single license version in the project "test" for the client "abc"
2)can I convert single license to extended license in a month of purchase
Hi, regarding to licenses it's important the purpose of your project. If you will use the template for one project for one client, Single License is Ok.
The Multiple license is similar to Single, but consider it as a volume discount. In the future, if you decide the template will fit for many of your projects, let say more than 3 projects for example, Multiple license will be better for you.
Extended license only applies when your project is created for more than one client, and all those clients are charged for the use of your end product, being a service or another product for resell.
Regarding to versions included, the product "Angle" comes adapted to different frameworks (angular x, netcore, rails, etc), since it's only one product, the chosen license will apply only for the project version you decide to use.

Regarding to upgrade license, unfortunately that's not possible for the moment.

Let us know if you have any question
Regards
Hi,
I want to purchase the theme, but i have some queries on this.
1) In my assistance I have multiple technologies, so can I install the multiple versions in multiple servers ( means: Angular5 + CLI, ReactJS +HTML, Jquery, ect. ). i want to install the angular5+Cli version in one server and Reactjs in another.

2) Also is there any possible to maintain different versions for Development ,Testing and Production of each build.
Is there any contact number available/ chat.
Hi,

1- You can use any version included in the package, only is necessary to consider that licenses will apply for one project version. Anyway depends on your project needs according to license terms.
2- Our projects are mainly delivered for development purposes and working fine for production environments (those version are the one you can check in online demo) we don't include many tools/test cases for testing purposes but depends on the project. Regarding to support, we only provide contact via this comment section or email.

Regards

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
11424Purchases

Licenses: Details »

Single application $24
Version:3.8.3
Type:
  • HTML Template
Bootstrap: Compatible with 3.1.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 9, 10, 11
  • Latest Chrome
  • Latest Edge
  • Latest Firefox
  • Latest Safari
Uses Less:Yes
Uses Sass:Yes
Categories:
Tags: admin, admin template, angularjs, material, meanjs, meteor, mvc, rails, responsive, rtl
Item#:WB04HF123
Released:3 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
themicon

themicon

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: