112 comments

node v6.9.4
npm v4.2.0
I am new to angular and interested to buy this theme (for my angular 2 application) and looking for following clarification:

1. Is this project built using @angular/cli? If yes then what is the current supported version?
2. Angular 4 would be released this month and would like to use it. When can I expect this theme upgraded for angular 4 and do I get free upgrade?
3. Why this theme is not available in google material design?

Thank you.
Hi,

Thank you for your message.

1. Yes, we use @angular/cli 1.0.0-rc.0. We're going to update version to 1.0.0-rc.1 this week.
2. We will update angular to 4.0.0 as soon as stable version will be ready.
3. We have great designers on board, so we use our own style guides.

Regards
Lukasz
dawlys PURCHASED
Hello,

Is it possible to get a doc explaining how to deploy angular 2 theme version on Heroic please ?

Thank you in advance.

Regards,
mike_ PURCHASED
Hello,
is possible to have the css style of the template separate from that of bootstrap?
Now we have a single style.css and is very difficult to maintain update bootstrap.
Thanks
Hi, We keep all our project up to date. It means that our project based on latest version of Bootstrap.

You can separate bootstrap styles and our styles, but this is not good solution because you will double the size of CSS files. If you want to separate our style you have to overwrite many bootstrap classes and this generate extra code.

In Clever we keep all bootstrap source files in SCSS/bootstrap_src, so all you need to do is copy latest version of bootstrap scss files to this folder.
I've downloaded your latest update.
ng serve no longer works: 'You have to be inside an ember-cli project in order to use the serve command.' ...
same error on both cli starter and cli full projects ...
Please advise.
bash-3.2$ ng --version
angular-cli: 1.0.0-beta.24
node: 6.5.0
os: darwin x64
@angular/common: 2.4.8
@angular/compiler: 2.4.8
@angular/core: 2.4.8
@angular/forms: 2.4.8
@angular/http: 2.4.8
@angular/platform-browser: 2.4.8
@angular/platform-browser-dynamic: 2.4.8
@angular/router: 3.4.8
@angular/upgrade: 2.4.8
@angular/cli: 1.0.0-rc.0
@angular/compiler-cli: 2.4.8
Angular-cli has been updated to new version, so you have to reinstall angular-cli.

Please remove node_modules and install them one more time or reinstall angular-cli

How to do this?

Reinstall global package:

npm uninstall -g @angular/cli
npm cache clean
npm install -g @angular/cli@latest

or

Reinstall local project package:

rm -rf node_modules dist # use rmdir on Windows
npm install --save-dev @angular/cli@latest
npm install
I'm interested in angular2 version. Do you use some jquery plugins or your template is angular-style?
You are awesome! Only Angular libs is what i need, thank you.
I'm glad you like our work
Update will to angular4 version????
We're testing Angular 4 Version. It should be ready at the end of this week.
Great !!!!!
Hello, can I use the Lazy Load Module in Agular version 2? And it is using the right CLI / webpack? Thank you
This version use Angular CLI and Webpack. Yes you can use lazy loading.
kchojhu PURCHASED
I see that you replied to Angular 4 update. Please make this happen and hopefully soon. Great work on the templates!
I would like to use your theme on a Meteor/Angular 2 environment
How complicated does it sound ?
Thx
Hi, is this template ready with Angular 4? If not can I get update after purchasing Angular 2 version..!

thank you
Hi,

We're testing Angular 4 version. It will be ready next week. You will get free update if you buy this version.

Regards
Lukasz
Hi,
I was checking your template to see if I want to buy it, but I noticed some issues in the preview demo:
- All the buttons in the bootstrap 4 version don't have the hand icon on hover -> so there is no visual feedback for the user that this is a button/an action
- the dropdown buttons don't seem to work in the Angular 4 version!

regards,
When will this version of the template support minifying the sidebar so only icons show? (like in the bs 3 version). Thanks!
Hi, please add sidebar-compact class to body tag.
Get error on Angular4_CLI_Starter.

'/node_modules/ng2-bootstrap/dropdown/index"' has no exported member 'DropdownModule'.'

Only just bought this. Didnt think i'd need to fix errors straight away.
Any ideas?
turns out, need to replace DropdownModule with 'BsDropdownModule' in app.module.ts and the starter kit now compiles. :)
Thank you. I will fix it.
mrukab PURCHASED
is there a welcome page could be as main page for the site ?
All available pages you can find on template demo. If you can't find something please send me some examples. We will consider if we can add something like that in future releases.
mrukab PURCHASED
Hi, just bought the template, in angular 4 version when I click in profile image or any icon in main header it auto navigated to dashboard page. any suggestion to fix this ?
Hi,

Please add (click)="false" to dropdownToggle element.
I will add this solution in next release.

Regards
Lukasz
mrukab PURCHASED
Thanks a lot
vdavi PURCHASED
I just downloaded latest version. It looks like only the angular_cli project was updated to Angular 4 and Bootstrap 4. Regardless, I'm running 'ng build' and receiving this error. Please advise:
Bootstrap 4/Angular4_CLI_Starter/node_modules/ng2-bootstrap/dropdown/index"' has no exported member 'DropdownModule'.
Thank you for your message. We know about this issue, there is problem with ng2-bootstrap component. You have to change DropdownModule to BsDropdownModule and everything should be ok. We will fix this issue next release.
First of all nice template, very clean. Its the first I bought in which I started coding right away instead of reworking it. Kudos and thank you for that. But here are my points for improvements. First thing I find a bit disappointing that you have not styled the bs4/ng2 template to recommended practices of angular components. You are applying old practices to new paradigms; scss files belong with and scoped to their respective components, not bunched up together in a global styles folder which breaks the webcomponents view-encapsulation paradigm. Second please readup on the :host pseudo selector without it the components are improperly styled. And third update the dependencies to the latest version. I had to quite some work to get the template working.

Regards,
Wendell
Hi, thank you for your feedback. We're working on most of this issue and we will solve them in future releases.
nasy PURCHASED
Hi, nice theme, i like it so far.

There is a problem with the dropdowns though, none of them appear to be working. Any idea why?

https://genesisui.com/demo/clever/bootstrap4-angular4/#/forms/basic-forms
Hi,

Thank you for your feedback. Do you have any js errors in console?

Regards
Lukasz

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$39
1259Purchases

Licenses: Details »

Single application $39
Version:2.4.11
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Edge
  • Latest Firefox
  • Latest Safari
Uses Less:Yes
Uses Sass:Yes
Categories:
Tags: admin, angular, angular 5, angularjs, bootstrap 4, dashboard, inspinia, react, smartadmin, vue
Item#:WB07JN5T9
Released:3 years ago
Updated:Yesterday
Sold exclusively on WrapBootstrap
creativelabs

creativelabs

Signed up 5 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: