110 comments

This theme is one of the worst documented themes. How can you assume that all those people who buy your themes are Ruby Experts? So many same file names here and there don't know what to pick up from where. This is Ridiculous!

The guides are the worst guides that I have ever read. You should at least warn your users before buying this theme that all the things are in middleman and .erb format.

Though the design of the theme is good but the organisation of the folder structure is UTTER BULLSHIT!

I really suggest that you refactor your documents and let people know how to do their own changes and stuff.

And I have bought tons of themes from wrapbootstrap but I must say that this is the worst documented
theme.
Since this is the closest thing that we have to a 'Forum', has anyone tried to implement the Dashboard in MVC? I've bundled the CSS and JS files and added the @RenderBody(). My 'Home.index' includes an Emerald Panel with panel-actions... fullscreen, collapse, close. It all renders beautifully, but clicking on the icons results in nothing. No errors, no nothing. Any suggestions would be appreciated.
OMG, never mind. I was missing the rel="panels" attribute in the row!
Are there plans to update to Growl 2.0.1?
I like the design and functions - But I dislike the Ruby, SCSS and coffeescript bundling. The "build" version has only a 3MB (!) .js file containing everything - same thing for the css file (one file 1.75MB). Source folder only have coffeescript and scss files...

I've bought this to modify it to my needs but I don't want to learn coffeescript and SCSS. This makes modifications much more difficult than in other themes I've bought... Most of admin application are REST -> I don't see a reason for the ruby templating engine which also make things complicated...

I would please you to add alternative option that is bundled like other templates here (clear, documented javascript and css). I buy templates to save time and not to waste my time in learning things I personally don't want and need... I own e.g. the "SmartAdmin" template too which is absolute brilliant documented and easy to modify.

I hope you can find a option to release a "normal" version of this beautiful theme.

Thank you very much
alface PURCHASED
Bought this to save my time but instead im walkin in circles trying to find what does what in this mess.
The documentation is next to useless, i cant find a way to use only the parts i want cause there is no way to know what plugin does what and they come all bundled together...
Turbocards would be more useful if the BACK CONTENT could be inline. Remote URL's are of limited use in some JS heavy apps, such as with ember.js.
Is there any good documentation for this theme? I'm trying to write a dynamic menu system (can change depending on the needs of the user / application), but the menu system's DOM model and javascript are a nightmare.

I've emailed you twice, and you haven't replied in the last 60 days.

Please explain or provide documentation on how to properly code the navigation. (And then update it after page load)

My employer did purchase this theme - we're paying customers and you need to explain how on earth we're to use this thing.
My employer is evaluating both Emerald and SmartAdmin. We really like the look and feel of Emerald, but the apparent lack of support is a major concern. Could you release a roadmap or announcement of future improvements/releases for the Emerald Theme?
My website is built with html,php,and css; and I like to use it as an admin backend page, can I integrate it with this?
Yes. You can use the css and js files in the dist folder.
neotoze PURCHASED
It will be a massive amount of work do build anything dynamic out of it. I bought it and it was a waste of money.
neotoze PURCHASED
Things are so much tied together that it's ridiculously hard to build something from this. Wanted to build an angularJS app and after a couple hours opking around I don't even know where to start.
Also im no expert in ruby and don't feel like learning a new language just because of a theme...
I don't recommend this unless you plan to create a static website, even for less than $20 it's a ripoff.
I am having an issue with JQuery not recognizing partials brought in via Angular. I looked into using $viewContentLoaded but I don't know what functions to call in that for it to work. For example the left sidebar is in an Angular partial but JQuery can't find the oc-wrapper div. Can you help me figure out how to get JQuery to recognize the partials from Angular with this theme?
You need to wrap each jq call with a directive. That's just how angular works.
I'm confused how it says this template uses JQuery UI but the following comment says Angular is not compatible with JQuery UI. Could you clarify that?

https://github.com/angular/angular.js/issues/10933#issuecomment-72442447
To use jquery stuff with angular you usually need to wrap it in a directive.
Angular jquery passtrough plugin from the angular-ui project makes that reasonably easy:

<button ui-jq="button"></button>

"Developers" that don't know nothing about nothing try to do it the old jquery way (onload function that searches the dom and calls jq stuff) and when they see that that doesn't work they prophesize that jquery ui not compatible.

Jq UI is optional in Emerald. We just style the standard jq ui components in case you use them so they are in line with the theme look and feel.
The documentation (if we can say there is any) is one of the worst I've seen. The build from rails is just useless. I would strongly recommend to shut down this product until it is refactored.
Hi,

Wanted to build a quick pdt prototype for demo and need reusable angular controls.
Is there a list of angular elements?

Regards,
Parag
anawaz PURCHASED
Hi Folks,

Things have been working fine but after a Google Chrome update a few days ago I'm starting to get a JS error on Chrome (it seems to be fine on firefox). No matter what page I load, I get the following in the Chrome debugger:

Uncaught Error: Syntax error, unrecognized expression: .oc-'lg'-partial-leftSizzle.error @ application.js:1438
Sizzle.tokenize @ application.js:2052
Sizzle.compile @ application.js:2420
Sizzle.select @ application.js:2510
Sizzle @ application.js:844
Sizzle.matchesSelector @ application.js:1405
jQuery.fn.extend.closest @ application.js:2885
Collapse.inOcPartial @ application.js:99746
Collapse.show @ application.js:99764(anonymous function) @ application.js:17883
jQuery.extend.each @ application.js:376
jQuery.fn.jQuery.each @ application.js:140
Plugin @ application.js:17876
window.PanelView.PanelView.uncollapse @ application.js:97729
PanelView @ application.js:97666(anonymous function) @ application.js:97890
jQuery.extend.each @ application.js:376
jQuery.fn.jQuery.each @ application.js:140
PanelsView @ application.js:97886
(anonymous function) @ application.js:97927
jQuery.extend.each @ application.js:376
jQuery.fn.jQuery.each @ application.js:140
$.fn.panels @ application.js:97926
load @ init.js:54(anonymous function) @ init.js:221
jQuery.Callbacks.fire @ application.js:3074
jQuery.Callbacks.self.fireWith @ application.js:3186
jQuery.extend.ready @ application.js:3392
completed @ application.js:3408

Thoughts or solutions?

Thanks!
anawaz PURCHASED
OK, so I have managed to catch and fix the issue. The problem seems to be with BSEUtils.Mq.screen().

This method previously returned "lg" on chrome, but after a recent update, it returns "'lg'", giving us extra single quotes. I'm not sure if this is something the queueing system should fix in an update, but as I'm not using the ruby templates (I don't really need them - I've just dropped theme into our MVC framework), I've put in a fix in the application.js file.

The method Mq.screen() is used in many places. On line 97193, if you change:

return Mq.screenMq() || Mq.screenFallback();

to

return Mq.screenMq().replace(/["']/g, "") || Mq.screenFallback().replace(/["']/g, "");

that will remove any ' or " that come along, and you'll need to do this because the result is part of your JQuery selector, which, if it contains invalid characters, will break Sizzle (which JQuery uses).

if you're really keen, you can replace all other instances of Mq.screen() too, but this seems to have worked for me and the app now works fine on Chrome and FF again.
spee65 PURCHASED
Its pitty that make a user the fixes and not the author.
In Chrome are much things doesnt functional - no Submen├╝ for instance.
spee65 PURCHASED
no help, no support, think this theme is dead + no update since 11 month: think this theme is dead :(
Theme don't work like it should on chrome and IE. JS and CSS files are extreamly heavy.
I asked 9 months ago if there was a roadmap or plan to support. Needed work then, and needs even more now with all the new bugs. Sad.

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$18
507Purchases

Licenses: Details »

Single application $18
Version:1.1.0
Type:
  • HTML Template
Bootstrap: Compatible with 3.2.x
Layouts:
  • Responsive
  • Fluid
Browsers:
  • IE 9, 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: admin, admin template, responsive dashboard, webapp
Item#:WB01687J8
Released:3 years ago
Updated:3 years ago
Sold exclusively on WrapBootstrap
emeralddesign

emeralddesign

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: