298 comments

VladR PURCHASED
One more comment from me, again related to the left navigation. My left navigation menu (sub-element) is not static, but rather dynamic (loaded through ng-repeat). Your "highlightActive" directive is well written, but doesn't account for this - you "cache" links when directive is initialized, but at that point the sub-items through ng-repeat are not yet loaded.
So I ended up moving the:
links = $element.find('a');
inside the highlightActive = function (...) function - it adds a bit of overhead, but necessary if your menu is not static. Hope this helps someone.
V.
Again, thanks for the feedback.

Glad you found a work around :)
How can i add express server.js file to Gruntfile? I have tried many different grunt-express packages, can you help out?
Hi, thanks for your interest.

Take a look at this: https://github.com/DaftMonk/generator-angular-fullstack

I used to used this one, and it works well

Hope this helps :)
Hello!
I am unable to print this theme using Ctrl + P. Is there any way I can do it?
I am using chrome version 44.0.2403.107.
Hi,

Have you comment on the wrong item? Let me know if I am wrong, thanks!
I bought this theme without realizing it was in CoffeeScript and that it used several modern tools. I am using this to also learn CoffeeScript, Grunt, etc. I think I get most of it, but I was wondering about this section of the code in the Gruntfile. It seems like you are just setting up the client and dist paths. Why is there a yeoman task in the Gruntfile... is it ever run? What does it do?

Thanks a lot for a great theme!


# configurable paths
yeomanConfig =
app: "client"
dist: "dist"

try
yeomanConfig.app = require("./bower.json").appPath or yeomanConfig.app
grunt.initConfig
yeoman: yeomanConfig
Hi, thanks for purchasing.

Are you using the latest 2.0.0?

It's written in JavaScript now, sorry about the CoffeeScript thing, I realize it's just my personal preference.

Also, the reason there's yeoman task is that I start the project with yeoman-angular seed project instead of starting from scratch :)
Oh no, I am glad this was in CoffeeScript. It's not a big leap for me because I am familiar with Ruby.

That's what I guessed about Yeoman, but after about an hour of searching I was not able to confirm that myself. Thanks for the information.
lol, glad you like it :)

Yeoman is the workflow I used, because I personally like Grunt, Gulp and Bower

Of course, you can other alternatives if you like :)
I am developing a MVC application. If i buy this template with single application license, can i cut some HTML and styles to paste in some views and layout?

I asked because if there is a rule license validation, may be to hard to do.
By the way, i am trying to buy this template, but paypal refuse the operation. Have any problem with your account?

Tanks
Hi, thanks for your interest.

The item is on WrapBootstrap platform, I think their Paypal account is fine :)
Q: If i buy this template with single application license, can i cut some HTML and styles to paste in some views and layout?

A: Yeah, of course you can :)
paulcull PURCHASED
Hi. Is there an example app that shows how I can bind some data to rest services instead of the local data sets ?

Thanks
Hi, thanks for purchasing.

I am sorry there isn't a real backend example now.

However, because AngularJS is really popular now, you can find lots of similar examples online.

Also, Flatify works any back end you like, NodeJS, Ruby, Python, PHP...

Hope this helps :)
dotlife PURCHASED
hi, could you help me ?

I put tabset in data-ui-wizard-form, but not work?
Hi, thanks for purchasing.

Yeah, the basic wizard form in Flatify is not that powerful now.

Maybe you need something like [Angular wizard](https://github.com/mgonto/angular-wizard), or do you have any better suggestions?
wangzhi PURCHASED
Help~!

I'm a user from China, after I paid, I cannot download the product from the web site (Maybe because I'm in China??)

Can you send me from the email?? wangzhi@yeah.net

I'm sorry for my bad English, hope you can understand me...Thanks a lot!
Hi, thanks for purchasing.

Google service is blocked in China, and Flatify admin uses Google fonts.

You can remove that by remove Google fonts from index.html.

Just open ./client/index.html, remove the following code:

```
<link href='http://fonts.googleapis.com/css?family=Lato:300,400,700,300italic,400italic' rel='stylesheet' type='text/css'>
```

Hope this helps :)
wangzhi PURCHASED
Need Help!
When I enter 'grunt' or 'grunt serve' or 'grunt serve:dist' command.It returns me many errors like
'Warning:Command failed:C:\Windows\system32\cmd.exe /s /c 'compass.bat --version'
'compass.bat'
use --force to continue.
Aborted due to warnings.

What should I do?
I use Win7 os.
wangzhi PURCHASED
Ok...I forget install compass..... Now It's worked...
Sry..I'm noob = =|||
No worries, thanks for telling me know :)
wangzhi PURCHASED
This system takes Angular+Bootstrap as the framework,i'm sorry that i am not familiar with Angular,could you send me the HTML version?Thanks!
Hi, thanks for purchasing.

I am sorry there isn't a pure HTML version.

Sorry about it.
Hello,

Could you help me with the HTML version please, I just purchased this theme and I need this version in order to start working. And if you please have more documentation about it.

Thanks
Hi, thanks for purchasing.

I am sorry there isn't a pure HTML version.

Sorry about it.
wangzhi PURCHASED
Help~
I don't need Multi-Languages.How could I remove that and do not affect the other pages?
wangzhi PURCHASED
ok.. I missed the Module in app.module.js...
Did you have more specifically document of modules for tell us what's the module to do.
Sry.. I'm angularJs noob..and Bad enghlish = =||||
wangzhi PURCHASED
I just need head nav... and use angular to change the content view....What's .js should I remove....?
There're many .js in index.html.. I try to remove one ...the page will be have problem.... plz... help
/(愒o愒)/~~
Hi, sorry for the late reply.

Removing the multi-language functionality won't affect other pages.

In short, you can remove it like removing a angular module.

Basically, at least, you need to do the following:

1 remove it in index.html

2. remove 'app.i18n' module in ./client/app/app.module.js

3. Change all the i18n directives, for example change `<span data-translate="GRIDS"></span>` to `<span>Grid</span>`

Let me know if you need more help.

Btw, you can email me from my profile page :)
coltforty PURCHASED
Hi Arousing,
I have found out how to get your form wizard to work, but still having a few issues with it.
I am hoping that we can work together to get it working 100%. I really love your theme and and appreciate all the work you have done on it, but the main thing I need is a the form wizard.

So here is what I have found:
Inside <div data-ui-wizard-form> you need to include an additional wrapper <div class="steps-wrapper">

So it should look like this
```
<div data-ui-wizard-form>
<div class="steps-wrapper">
<h1>Initial Set Up</h1>
<div></div>
<h1>Review</h1>
<div></div>
</div>
</div>
```

Then next thing is to add to the "uiWizardForm" directive and attach the form wizard to the controller scope. That way you can run your methods from the controller.
```
.directive("uiWizardForm", function($compile)
{
return {
restrict: 'A',
link: function(scope, ele)
{
steps = ele.children('.steps-wrapper').steps({
onStepChanging: function (event, currentIndex, newIndex)
{
return scope.onStepChanging();
},
onFinishing: function (event, currentIndex)
{
return scope.onFinishing();
},
onFinished: function (event, currentIndex)
{
scope.finishedWizard();
},
});
$compile(steps)(scope);
}
}
});
```
Now everything is working except I am unable to access the parent controller from the ui-wizard-form.
I am unable to access variables or create a ng-repeat with variables created in the parent controller.
Any help would be greatly appreciated.
coltforty PURCHASED
So I swapped out the "link" for "compile" and that allows access to the parent controller.
However with "compile" there is no access to scope so I can't attach the ui-wizard-form methods to the parent controller methods:

```
.directive("uiWizardForm", function($compile)
{
return {
restrict: 'A',
compile: function(ele){
var steps = ele.children('.steps-wrapper').steps();
}
}
});
```

Do you know how I can get access to to scope from the compile method?
coltforty PURCHASED
Ok, I got it working for me. I need to create a Reference to scope within the directive. Then assign it in the controller method of the directive.
```
.directive("uiWizardForm", function()
{
var scope;

return {
restrict: "A",
controller:function($scope,$element){
scope = $scope;
},
compile: function($element){
var steps = $element.children('.steps-wrapper').steps({
onStepChanging: function (event, currentIndex, newIndex)
{
return scope.onStepChanging();
},
onFinishing: function (event, currentIndex)
{
return scope.onFinishing();
},
onFinished: function (event, currentIndex)
{
scope.finishedWizard();
}
});
}
};
});
```
Hi, I saw your email.

Thanks for taking the time to share the code, really appreciate it!

I am planing to change it to angular-wizard in the next update to make the wizard better, as the default jquery-step is quite primitive.

Sorry for the inconvenience.
coltforty PURCHASED
What is your best guess as to when you might have that done?
Thanks
Hi,

I am sorry that I don't have an exact time frame for it now.

However, probably coming next month
coltforty PURCHASED
No worries,
Thanks for the response.
wangzhi PURCHASED
Help~
I had to use a Jquery plug-in. And It must use dom first like
$(document).ready(function () {
$('#sel_Country').chosen();
});
It works when first time.
but when you change page, the jquery ready event run fast than ng-view, So the " $('#sel_Country') " get last time page's element.

How can I use the Jquery plug-in?

plz help me.
wangzhi PURCHASED
OK... I remove the ngAnimate module ...It works ...
ngAnimate make the page problem.....
Hi, sorry for the late reply.

Personally, I don't suggest to use jQuery plugin this way, maybe a custom angular directive will be better.

Hope this helps :)
Hi everybody, it does not work with Chrome Version 48.0.2564.116 m
Any help ?
Thanks
Which is the last version i guess ? my browser telling me that it is updated,
Thanks in advance
Highcharts does not work ... do you have some advices please ?
Thanks
Hi, It seems you haven't attach your order to your account.

Let me know if I am wrong, thanks :)
c-myers1 PURCHASED
The sign-in page looks funny on Android default browser. The heights of the mail and password icons are larger than the input field heights. This must be a little matter that can be easily corrected, can you direct me? This is on Android 4.0.4 though.
c-myers1 PURCHASED
Hello arousing. I would appreciate your response on this. Thank you
Hi, sorry for the late reply

Plan to do a big update to Flatify this month, I'll add this to my list.

If possible could you email me through my profile page: https://wrapbootstrap.com/user/arousing

Thanks for the feedback.
c-myers1 PURCHASED
Hi arousing,

When is this update coming out?
Sorry for the delay.

Should be in 2 weeks if thing goes right.

Sorry about it.
c-myers1 PURCHASED
Well done for the release. It reads 22/05/2015 so you might want to update this to 22/050/2016.

The simple issue I mentioned is not fixed though. I sent you the screenshot: the sign on page still appears funny.
Thanks for the feedback, just have fixed the typo :)

And let me fix the style problem in the next update.

Was thinking to do a big update after Bootstrap4 RC comes out, however it's still in alpha
Hi,

Impossible change value graph in the code angularjs, from php/array/json,..
Yet in the debugger the values of the graph are the same.

let me know how do you change value from php/data/json.

Thank for all
gerald.
Hi, sorry for the later reply.

So you want to render the charts with back end data?
I am facing a problem with the form wizard. When i try to put a form with more than 4-5 rows as a step content the panel hides them. So, only a part of my form is visible.

Could you assist me ?
Hi,

It seems you haven't attach your order to your account. As a result, WrapBootstrap didn't add the "purchase" tag next to your username.

Let me know if I am wrong, thanks :)
Hi,

It seems you haven't attach your order to your account. As a result, WrapBootstrap didn't add the "purchase" tag next to your username.

Let me know if I am wrong, thanks :)
Hi another thing with the form wizard is that does not accept angular translations.
marb180 PURCHASED
Hello, can you please provide feedback on the form wizard and angular translations cause it does not seem to accept them.
marb180 PURCHASED
any news?
Hi,

I am gonna do a big update to Flatify recently, coming in weeks

By then, form wizard will be changed to using angular-wziard

Hope this helps :)
marb180 PURCHASED
Thank you for your reply... i think that helped :)
Since you are working on form wizard improvements please take into account that ng-include directive does not work either.

I suppose that using angular wizard will solve this too...

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$15
2568Purchases

Licenses: Details »

Single application $15
Version:3.2.0
Type:
  • HTML Template
Bootstrap: Compatible with 3.3.x
Layouts:
  • Responsive
  • Fluid
Browsers:
  • IE 9, 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: admin template, admin theme, angularjs admin, angularjs dashboard, angularjs theme, bootstrap admin, bootstrap dashboard, dashboard template, dashboard theme, flat design
Item#:WB0977873
Released:3 years ago
Updated:3 months ago
Sold exclusively on WrapBootstrap
arousing

arousing

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: