185 comments

mgafur PURCHASED
I've bought this theme but have not used in our project, i am waits for angular 4 version
It's coming along nicely, you won't be disappointed :)
mgafur PURCHASED
thank you
Hi,

Im not much familiar with angular 2.I got angular 2 version file when i purchased this theme. how could i use this with angular 1.x version???
Hi,

I've not released a angular2 version with this theme, I'm working on releasing a angular4 version soon which is much like and compatible with version2. However both are completely different than angular 1.x
In order to use with version 1.x you'll need to take the html from the static version and create your template files and re-write all of the jQuery binds from the static version and make angular 1.x binds for your events, components, etc.
angular 4 version...???
Working on the seed version right now, coming asap.
ok
thank you...
i want start new project...
Hi,

The theme is great, I did purchase the theme last week and downloaded, The Files you are provided is node js version (I really dont have idea about node js), I need it in static HTML because I am going to implement this in an Angular + ASP.NET Application. Please provide static HTML
Hi,
There is a complete static version included. Node is only being used during development to compile all of the JavaScript and sass files into one, and to download all of your project dependencies.
mgafur PURCHASED
angular 4 version has been release, thank you. it's work excelent
Thank you very much!
angular js 4 version demo
JeremyT PURCHASED
I notice the angular seed and jquery seed have some different in style and the wall it display. Did you do it because of some kind of limitation? Or are you planning to make them the same? For example, the right fly out in angular has different effect to jquery version.
Hi,
Yes they're slightly different in design, this was done to work with Angular's Material Design Framework. It was better to work with their built-in ones than to fight it, I guess it was sort of a limitation but it really made the code much cleaner in the long run. Hope that was not a problem for you.
pncuong PURCHASED
Template errors when used on iphone 6, faulty nav does not display correctly
Hi,
I'm not seeing any issues on iPhone 6, everything works extremely fast and smooth from my testing. Can you be a little more specific, are there any actions you performed? Please email me any screenshots and/or console logs you may have to help debug your issue to support@authenticgoods.co
pncuong PURCHASED
When you scroll a small segment. Click on the left slide bar and it will see an error. This is only on Iphone using safari. I have tested the main page is still faulty.
http://www.authenticgoods.co/wrapbootstrap/themes/materiallab-v1.5/
return `<div class="country"><img style="max-width:45px;margin:10px;" src="assets/img/icons/flags/${country.countryCode}.png"/><strong>${country.countryName}</strong></div>`;

I need to config variable for asset path in js script.

I don't want to modify path by myself in all javascript which use asset file.

because my website use multiple theme then i moved assets to material-lab/assets

return `<div class="country"><img style="max-width:45px;margin:10px;" src="material-lab/assets/img/icons/flags/${country.countryCode}.png"/><strong>${country.countryName}</strong></div>`;

i changed assets/img/icons/flags/${country.countryCode}.png to material-lab/assets/img/icons/flags/${country.countryCode}.png
Hi,

I'm not sure what you're asking from me, is there something I can do?
you should not write like this

src="assets/img/icons/flags/${country.countryCode}.png"

but

can you write like this

var assetFolder = 'assets';
src="' + assetFolder + 'img/icons/flags/${country.countryCode}.png"

then move your

var assetFolder

place in global config file.
That's a valid point and a good suggestion. I'll take a look at making these changes in a future release.
Getting this error each time I press enter key on any textbox

Cannot read property 'blur' of null
at HTMLDocument.E.s._onKeyChange (vendor.bundle.js:41)
Hi,

Thank for reporting this, I'll take a look at it.
Please Update me on this, its a bit urgent
Look like a bug with the Pikaday plugin https://github.com/dbushell/Pikaday/issues/611
Removing the plugin from our codebase resolved the issue, so if it's urgent I would recommend doing that. I'll work on digging in deeper and see if they have a fix for it for our next update.
Hi, Thanks for the reply :) , Please explain me how to do that? (Sorry, I am a beginner)
Do you have an Angular 4 preview available?
Hi,
I don't have it loaded on the server, its just included in the download package. Please note it's
only the Angular 4 seed version, the Full Angular 4 version is still being developed. Just want to make sure you read that in the description so there's no surprises. :)
Hi. i'm new in angular 2. and I'm having this error when I run ng serve:

TypeError: Cannot read property 'config' of null
at Class.run (/Users/kamei/Sites/crm.dev/node_modules/@angular/cli/tasks/serve.js:21:63)
at check_port_1.checkPort.then.port (/Users/kamei/Sites/crm.dev/node_modules/@angular/cli/commands/serve.js:110:26)
at process._tickCallback (internal/process/next_tick.js:109:7)
Hi - do you have the node_modules folder and the .angular-cli.json file in your root directory?
HI. thanks for reply. I think it about versions of angular cli or something, I started a new project and copied the files inside src and the .angular-cli.json and it works.

Do you have some documentation? thanks.
Great! Glad to hear you got it complied, there's a documentation folder in the root project folder. That documentation will cover both the Full jQuery and the Angular 4 seed project.
Hi @authenticgoodsco, is it possible to provide datatable export feature, template javascript files clashes with my jquery code I wrote to export, my code works fine when I remove template .js files, Thank you
Hi,
That' something I can consider adding in the future, but will not be able to add it any time soon. Can you email me what errors you're seeing in the console, maybe we can quickly debug your problem.
When i run this command "ng serve" i receive this error:

86% hashingcrypto.js:74
this._handle.update(data, encoding);
TypeError: Data must be a string or a buffer
Hi,
Are you running the latest version of webpack? I've never received that build error but found something that might be related to your issue here. https://github.com/angular/angular-cli/issues/5756
We are purchased a MaterialLab Admin + Angular CLI Starter 1.5 theme. we are integrating this theme in to our angular js 2 app. we are using currently your angualr seed provided in your theme.

We are facing some problem in integration

we can't able to load styles of forms,animations,tables design are not loading in our
app. could you please help us to solve this issue ?

do you have complete seed of angularjs 2 complete seed ?
Hi,
Sorry to hear you're having some problems, please email me any error log files you have to support@authenticgoods.co and I'll get you squared away.
Hi,

How do I change the starting date of the date-picker, now it starts at the current date. I want it to start from 10/10/1950
Both date-picker and date-picker-range

Thank you
Anybody could help please
Hi,
You would use the setDefaultDate method, here's the documentation on it. https://github.com/dbushell/Pikaday
qorbani PURCHASED
I would appreciate if you can add File Manager and Task Manager like your MaterialWrap.
micole PURCHASED
Hi, when will you release the full Angular 4 version?
Wrapping it up right now, should be ready by next week.
Looking forward for a next update, great work and iam always excited for new features/pages. Best admin theme on Wrapbootstrap!
Thank you very much!

Working hard on the Angular 4 Bootstrap 4 project, hope to have it ready very soon.
First of all thanks for this stunning theme!

After following the documentation I'll get deprecation and errors, should I/we do anything about it?
Will it be updated on the next release?

Warnings / Deprecations:

npm install
npm WARN deprecated gulp-minify-css@1.2.4: Please use gulp-clean-css
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated express@2.5.11: express 2.x series is deprecated
npm WARN deprecated connect@1.9.2: connect 1.x series is deprecated
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.

> node-sass@3.13.1 install /Users/mikeploeger/Sites/assets/leckerio.symfony.local/design/MaterialLab-v1.5/jquery-seed/app/node_modules/node-sass
> node scripts/install.js

...
Error #1:

Downloading binary from https://github.com/sass/node-sass/releases/download/v3.13.1/darwin-x64-57_binding.node
Cannot download "https://github.com/sass/node-sass/releases/download/v3.13.1/darwin-x64-57_binding.node":

HTTP error 404 Not Found

...
Errors #2:

gyp verb command configure []
gyp verb check python checking for Python executable "python2" in the PATH
gyp verb `which` failed Error: not found: python2
gyp verb `which` failed at getNotFoundError (/Sitedesign/MaterialLab-v1.5/jquery-seed/app/node_modules/which/which.js:13:12)
gyp verb `which` failed at F (/Sitedesign/MaterialLab-v1.5/jquery-seed/app/node_modules/which/which.js:68:19)
gyp verb `which` failed at E (/Sitedesign/MaterialLab-v1.5/jquery-seed/app/node_modules/which/which.js:80:29)
gyp verb `which` failed at /Sitedesign/MaterialLab-v1.5/jquery-seed/app/node_modules/which/which.js:89:16
gyp verb `which` failed at /Sitedesign/MaterialLab-v1.5/jquery-seed/app/node_modules/isexe/index.js:42:5
gyp verb `which` failed at /Sitedesign/MaterialLab-v1.5/jquery-seed/app/node_modules/isexe/mode.js:8:5
gyp verb `which` failed at FSReqWrap.oncomplete (fs.js:152:21)
gyp verb `which` failed python2 { Error: not found: python2
gyp verb `which` failed at getNotFoundError (/Sitedesign/MaterialLab-v1.5/jquery-seed/app/node_modules/which/which.js:13:12)
One more error, after I installed everything like it was stated in the documentation, I can't run:

webpack -w
-bash: webpack: command not found

gulp is working fine.
Hi Limebulls,

I'm glad you like it! Let's try and get this sorted out for you. Can you tell me which version of node and npm you're running? If you're running version 5 or above of npm you should have received a generated lock file in your project's root directory during installation. The file will be called package-lock.json will you email that to support@authenticgoods.co please. If you're not running at least version 5, please update your npm to the latest version to receive this generated lock file. Also if your build failed during your npm install you'll receive a npm-debug.log file in your project's root directory, please include this file as well. This will help me further diagnose your issue.
1.)
The solution for the web pack problem (shouldnt this be in the documentation?):
Install web pack globally:
npm i -g webpack

Now it can be started.
---
2.)
One proposal, since web pack is a dependency only in development, shouldn't it be in:

"devDependencies": {

instead of

"dependencies": {

inside package.json?
----
3.)
The 404 mentioned above from node-sass doesn't seem to have any negative side effect, theme seems to be working correctly.
Hi,

Yes, I totally agree with you on both points. I apologize for that, and I'll include that in our docs as well.

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
374Purchases

Licenses: Details »

Single application $24
Version:2.2
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: admin, angular 4, bootstrap 4, calendar, charts, chat, contacts, ecommerce, file manager, material design
Item#:WB0G60N92
Released:8 months ago
Updated:2 months ago
Sold exclusively on WrapBootstrap
authenticgoodsco

authenticgoodsco

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: