185 comments

FullWidth v2 does have an styling error in macOS 10.12.6 (Safari):
https://ibb.co/nDuTSQ
Hi again,

Not sure how that slipped by us, thank you for reporting this. I took a look at this and it seems to be an easy fix, please change your class header-xs to header-sm. Here's a screenshot of the fix and I'll be sure to include this in our upcoming release. https://snag.gy/pBW049.jpg
Thanks!
One more misalignment bug, your example code in v 1.5:

<div class="profile">
<h4 class="card-title">MW</h4>
</div>

Your example is MW, which looks great, MW is perfectly aligned in the center:
https://snag.gy/2Ri3l8.jpg

But if you change it to MI or US by example, it is misaligned (not centered):
https://snag.gy/ToIrKP.jpg

To fix it do the following:

<div class="profile">
<h4 class="card-title text-center">MI</h4>
</div>

and change this css content, old:

.card-heading.card-img .card-title {
...
text-indent: 9px;

new:

.card-heading.card-img .card-title {
...
/* text-indent: 9px; */ <-- line removed

Result:
https://snag.gy/zshycY.jpg

Would be great if you could add it into the new release.
One more bug (but without known fix) on every page with sidebar:

The footer is always too long if a sidebar is available.
The Subheader does have the correct width, but not the footer.

You can always scroll to the right because, if a sidebar is present, pictures:
https://snag.gy/VMw5tE.jpg
https://snag.gy/DQcFMT.jpg

Do you have a quick fix for this behavior, that the footer is only 100% of the available width (like the sub header)?
Trying to reproduce this, but I'm not sure how you go the layout in that state. The sidebar menu should not be overlaying the content like that until you hit the tablet breakpoint, in which case you should have a background overlay like this: https://snag.gy/rtcNm1.jpg
Thanks for that fast reply! It is actually quite simple.

My resolution on MacBook Pro 15": Default ("Looks like 1440 x 900")

Visit: http://www.authenticgoods.co/wrapbootstrap/themes/materiallab-v1.5/

Now with the mouse inside the windows, you can scroll with the trackpad to the right (which we shouldnt) because the footer is too long.

Ive recorded a video for you, for better understanding:
https://www.youtube.com/watch?v=9mwuYeaftos&feature=youtu.be
Ive fixed the bug in the design:

#content_outer_wrapper #content_wrapper
has to be position: relative instead of absolut.

and then padding-button from the sidebar has to be removed.
micole PURCHASED
Any news for the full Angular4 version?
Great work, awesome template. Hanging out for the full Anguar 4 version:-)
silly question- kind of new to assets and design, but it shouldn't be hard to get this into the rails asset pipeline, right (other than the normal sass building, etc)? by the sounds of it, the angular specific stuff is really just seed and example application stuff, not specific to the javascript and css assets? am i missing something?
*bump*
Hi,
My apologies I totally missed your question. You're correct, the integration should be pretty easy. I've never tried integrating them so I could be completely wrong, but everything I've read about it seems pretty straight forward.
it's all good. i figured as much- (comments can get busy when you're successful ;)).

ty for the resp, looks like a great theme :)
Does this also include full MeanJS seed project? Thanks
Hi,
No it does not, sorry.
The next update for full angular 4?
Hi ,

We have purchased this template and using. everything looks good in the template. We are getting issues with floating labels. i.e. when we are setting the values to the input elements, floating label and values are getting overlapped. Is there any quick fix for this and also I suggest to have some examples with jquery ajax for some plug ins like select2, data table.
We believe that something may be wrong, we are not getting to fill datatable dynamically. Is there an example?
micole PURCHASED
How soon will you release the full NG4 version?
Hi,

Wrapping up the final build process on it now, it'll be ready within the next couple of days.
mdt414 PURCHASED
perfect theme,thank you
and would you please support select2.js for this theme?
Will the html5 version be upgraded to Bootstrap4 as well?
I and a ton of people doesnt use angular and just html5+jquery, can and if yes when can we expect the Bootstrap 4 version?
Yes that will be coming soon, not able to give a firm date but it should be ready within the next couple of weeks.
Awesome! Looking forward to it, the new angular version fixed a scrolling issue in the sidebar which the old Bootstrap 3 version is having. Would be great if there would be something like an upgrade path for existing customers.
Hi, authenticgoodsco,

Are you able to add the social buttons similar to below? it looks really great.
https://genesisui.com/demo/real/1.8.7/bootstrap4-static/components-social-buttons.html

Thanks
Hey,

Thank you very much! Yes, we have some pretty cool social media button for both the jQuery and the Angular 4 version. They're located towards the bottom of this page.. http://materiallab-angular.authenticgoods.co/#/user-interface/buttons
Thanks for quick response,
How about combine icons with text?
Hey,

Sure can, I'll put it on the list. It will probably take a couple of weeks before I'll have time to release it.
Hi
I am getting scrollbar issue with dropdown plug in, I have checked in your template. it was there on the following page (form-validation.html).
http://www.authenticgoods.co/wrapbootstrap/themes/materiallab-v1.5/form-validation.html

Issue: after footer, some space is adding and it is because of the dropdownjs plugin.

Please provide the fix and I haven't got any response for my previous comment. can you please provide the quick fixes for the issues
Hey,

Sorry for the late reply, I'm not seeing an issue on this. What browser/version and os are you seeing this in?
JeremyT PURCHASED
Hi there,
I tried to run your latest version (2.0) on local. I am getting few errors:

1) If I run npm install on either one of the angular version on a fresh environment, I am getting error "'typings' is not recognized as an internal or external command". I need to manually run npm install typings before i can run npm install. I didn't have this problem on v1.5 and it is not documented

2) After successfully run npm install, I getting following error when run ng serve.
"ERROR in D:/Projects/MaterialLab-v2.0/angular4-full/src/app/shared/shared.module.ts (18,2): Module '"D:/Projects/MaterialLab-v2.0/angular4-full/node_modules/@angular/material/material"' has no exported member 'MdCoreModule'.
ERROR in Error: MdCoreModule is not an NgModule"

I am testing both v1.5 and v2 on fresh environment.
The fix is out, please let me know if you have any issues.
JeremyT PURCHASED
Hi there,

After some research, and look like material have a new version 2.0.0-beta.11 which is not working with v2.0. Look like if I "force" the install to use just 2.0.0-beta.10, everything is fine.

Can you help to fix it so it work on the latest 2.0.0-beta.11?
Hey Jeremy,

I'm aware of this recent change breaking from Angular's Material and plan on fixing this right away. However I didn't think it was going to break MaterialLab because the npm lock file should have installed 2.0.0-beta.10 and not 2.0.0-beta.11 Are you using npm 5+ and if so, did npm automatically install the .10 and not .11? Regardless, I'm putting out the fix asap. I was just curious, it may be a reason for me to switch to yarn soon.

FYI it looks like they're dropping their "md" prefix as well. https://github.com/angular/material2/releases
JeremyT PURCHASED
Hi there,

Thanks for your quick reply. To answer your question.
1) I am using npm 3.
2) It automatically install the .11, but if I change the from "^2.0.0-beta.10" to "2.0.0-beta.10" in the package, it will only install the .10 version.

I will give the latest version a try.
JeremyT PURCHASED
Hi there,

I also tried to use the seed version, but getting the following error
Error: ENOENT: no such file or directory, open 'D:\Projects\MaterialLab-v2.0\angular4-seed\node_modules\malihu-custom-scrollbar-plugin\jquery.mCustomScrollbar.concat.min'
at Error (native)
The update fixed this well.
Hi,
Can we have a changelog to describe what are updates?


Thanks
Hi,

The changelog is below the thumbnail preview.
Hi, when I try npm install I get these errors:

@angular/flex-layout@2.0.0-rc.1 requires a peer of @angular/common@^2.2.3 but none was installed.
npm WARN @angular/flex-layout@2.0.0-rc.1 requires a peer of @angular/core@^2.2.3 but none was installed.
npm WARN @angular/flex-layout@2.0.0-rc.1 requires a peer of zone.js@^0.7.2 but none was installed.
npm WARN bootstrap@4.0.0-beta requires a peer of popper.js@^1.11.0 but none was installed.
npm WARN ng2-datepicker@1.8.3 requires a peer of @angular/forms@^2.4.0 but none was installed.

after I runned
npm install --save @angular/flex-layout@latest
and npm i --save jquery popper.js

I don't know if that is fine but now, I only have this error:

npm WARN ng2-datepicker@1.8.3 requires a peer of @angular/forms@^2.4.0 but none was installed.

but i don't find a solution for this. could you help me?

thanks. great template
i'm trying with the New angular4-full
The warnings are fine, I’ve verified them all during development. The popper.js file is not needed, that’s a Bootstrap 4 dependency only if you’re using the built in Bootstrap components with jQuery. In our case all of the Bootstrap components have been re-written in Anguar so the jQuery components are not needed.

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
372Purchases

Licenses: Details »

Single application $24
Version:2.2
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: admin, angular 4, bootstrap 4, calendar, charts, chat, contacts, ecommerce, file manager, material design
Item#:WB0G60N92
Released:8 months ago
Updated:2 months ago
Sold exclusively on WrapBootstrap
authenticgoodsco

authenticgoodsco

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: