1482 comments

I bought the template, but I am not able to use it in C #, can you help me?

Do you have the HTML version?

Thank you.

jeferson
Hi jeferson,

Have replied to your email.
@sketchpixy hello there, I have been waiting for the HTML version too, any news?
Hi,

I am using rubix react demo installation for my project. I am facing one issue while deploying my dist to different servers like development, staging and production. I want to change one url every time I create dist in any environment. Can I pass any parameter at the time of dist creation based on which url can be changed as per environment. Please provide your suggestion asap.
Hi divaa12880,

If you are creating a dist it shouldn't matter what the URL is as long as the contents of the dist is served from the root of your webserver. Just deploy the contents of the dist folder directly to the root of your staging and production webserver root and it should work without any modifications.
Hey sketchpixy!

I have a little problem with running example project. When I open localhost:8000 i get an error "FatalThrowableError in ReactJS.php line 64:Class 'V8Js' not found". I was looking for a solution to this error and a found your advice to make sure my laravel/homestead version is 0.5.0. I had advanced according to the advice and now I have another error which I can't handle. When I try to start VM a get an error "Failed to restart php7.0-fpm.service: Unit php7.0-fpm.service not found." I found a few tips that tell me updated Homestead but then I'am back where I started. What can I do?
Hi iteratorsmobile,

Looks like you still have a newer version of laravel/homestead even after installing 0.5.0. If you have a newer version, vagrant will by default pick up the latest version. So you would have to remove any version > 0.5.0.

Can you check:

$ vagrant box list

?

If there is a version greater than 0.5.0 please remove it like so (assuming it is 1.0.1):

$ vagrant box remove laravel/homestead --box-version 1.0.1

If you don't see laravel/homestead@0.5.0 you can always add it like so:

$ vagrant box add laravel/homestead --box-version 0.5.0

Once you have done then, destroy the VM and re-create it again like so:

$ vagrant destroy
$ vagrant up

It should work now! :)
Hello Sir,

what do you mean by "automating builds, Rubix uses Node.JS"
Is there NodeJS required?
Hi friendlycoding,

> what do you mean by "automating builds, Rubix uses Node.JS" Is there NodeJS required?

Yes. Only during development for: Laravel and Ruby on Rails seed projects. The rest of the seed projects use NodeJS even in production. If you are using distributable feature: http://rubix-docs.sketchpixy.com/node/creating-distributables you don't need NodeJS in production.

Hope this clarifies your doubts :)
Where are the docs for this? Am I overlooking this some where?
Hi ccastro7,

You can find the documentation in rubix/documentation/index.html. In case you don't have access to the file for some reason, we also provide online documentation here: http://rubix-docs.sketchpixy.com/

Hope this helps :)
roackb2 PURCHASED
Hi, I've bought the package but having serious problem to get it up and running.
I'm using koa.js as my backend and setup as the "Integrating Rubix in existing project" instructions, but I cannot get components to work correctly like NavBar. I try to copy files in the 'node-seed/src' folder to my own components folder, but styling of the components are totally wrong. Except for compiling the sass files, include the result css file in the pages, copy the public assets to my project, what else should I do to make it run? I'm relative new to the front-end world and get really confused to the complicated webpack settings and the assets serving mechanism in the node-seed project, can you help me?
Hi roackb2,

Have you also copied the rubix/custom-project/index.html within file as described in the "Integrating Rubix in existing project" instructions? If you are using a template for rendering the layout (like pug/jade) you can refer to the rubix/custom-project/index.html file for the correct way to create the layout. Make sure you have a "default" class (which corresponds to the "default" theme) for your <html> tag for the styles to be applied correctly.

Let me know if this fixes your issue. :)
roackb2 PURCHASED
Gosh you saved my life!
I forgot to add the "default" class to the html tag, which I once thought should be a minor one to ignore, and now I finally have a basic working example, thank you a lot!
Car Transportation in Delhi @ http://www.ezrelocation.in/car-transportation-in-delhi.html
Car Transportation in Noida @ http://www.ezrelocation.in/car-transportation-in-noida.html
Car Transportation in Gurgaon @ http://www.ezrelocation.in/car-transportation-in-gurgaon.html
Hello, a few days ago bought the template ¨Rubix - ReactJS Powered Admin Template¨, wanted to know if in any way could acquire the corresponding psd files.
Or someone who has them?
Attentive to comments
Hi gleniakl,

Apologies. We don't provide PSD files for Rubix. We are working on Sketch files and will be providing it for 4.3.0 update.
It's been several weeks now since an update due. Please give us an updated release date, if you could.
The reason I keep bugging you is that in one email I was told that some files will be moved into rubix folder for future third parties update. So I want to see which.
Thanks
Hi izeroman,

We have already provided you with the early copy of the final release of Apollo integrations which you had asked earlier. We won't be moving any files to @sketchpixy/rubix as we have decided it is best to allow access to router code instead of moving it to @sketchpixy/rubix (and we'll be doing the same for other integrations). So you can use what we have provided without worries and there won't be any requirement for upgrading as you already have the final copy.

We will release it once we have finished writing documentation/tutorials. There are quite a lot of improvements to the documentation (and quite a lot of tutorials as well) and will take some time to finish it.

Thanks for being patient.
Mariete PURCHASED
Hello.

I just purchased your template few days ago. My plan is to use it for Meteor (with React) to make an application but I'm facing some issues:

After installing, following the manual, I get some warnings:

C:\Users\melka\Mis documentos\meteor\rubix\meteor-example>meteor npm install
npm WARN deprecated watch@0.19.3: Install watch@1.0.0 instead
npm WARN prefer global node-gyp@3.5.0 should be installed with -g

At the end:

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.1

Now I do the meteor npm install and get two more warnings:

C:\Users\melka\Mis documentos\meteor\rubix\meteor-example>meteor npm install
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.1

And then I execute Meteor and get:

C:\Users\melka\Mis documentos\meteor\rubix\meteor-example>meteor
[[[[[ C:\Users\melka\Documents\meteor\rubix\meteor-example ]]]]]

=> Started proxy.
=> A patch (Meteor 1.4.1.3) for your current release is available!
Update this project now with 'meteor update --patch'.
=> Started MongoDB.
minifier-css: updating npm dependencies -- css-parse, css-stringify...
rubix:reactrouter:react-router-ssr: updating npm dependencies -- cookie-parser, cheerio, deepmerge...
minifyStdCSS: updating npm dependencies -- source-map...

Changes to your project's package version selections:

webpack:postcss added, version 1.1.2

Your package.json has been updated. Please, run npm install in your project directory.

I do again meteor npm install and get some more warnings. On particular this two:
WARNING: npm peer requirements (for reactrouter:react-router-ssr) not installed:
STDERR) - react-router@3.0.2 installed, react-router@3.0.0-alpha.3 needed

C:\Users\melka\Mis documentos\meteor\rubix\meteor-example>meteor npm install
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.1

C:\Users\melka\Mis documentos\meteor\rubix\meteor-example>meteor
[[[[[ C:\Users\melka\Documents\meteor\rubix\meteor-example ]]]]]

=> Started proxy.
=> A patch (Meteor 1.4.1.3) for your current release is available!
Update this project now with 'meteor update --patch'.
=> Started MongoDB.
webpack built 72406a5ce168693b833e in 23807ms-
W20170310-11:22:27.879(1)? (STDERR) WARNING: npm peer requirements (for reactrouter:react-router-ssr) not installed:
W20170310-11:22:27.985(1)? (STDERR) - react-router@3.0.2 installed, react-router@3.0.0-alpha.3 needed
W20170310-11:22:27.990(1)? (STDERR)
W20170310-11:22:27.994(1)? (STDERR) Read more about installing npm peer dependencies:
W20170310-11:22:27.996(1)? (STDERR) http://guide.meteor.com/using-packages.html#peer-npm-dependencies
W20170310-11:22:27.998(1)? (STDERR)
=> Started your app.

=> App running at: http://localhost:3000/
Type Control-C twice to stop.

Now in the console I get:
WARNING: npm peer requirements (for reactrouter:react-router-ssr) not installed:
- react-router@3.0.2 installed, react-router@3.0.0-alpha.3 needed

Something is not working fine here but I'm unable to debug what.
Hi Mariete,

These are just warnings about version mismatch and you can ignore them. The react-router version installed is 3.0.2 but what is added to peerDependency is 3.0.0-alpha.3 and hence these warnings are logged. Just visit http://localhost:3000 and you should see the app running.
Hello,
One of my coworker purchased it. We are integrating it in the existing Meteor app and we are currently facing a few issues. When testing locally the icons don't load none of them show. In addition perfect-scrollbar.js doesn't work
Thanks
Hi greem,

Are you using fourseven:scss for compiling the SASS stylesheets? If yes, then please get in touch with us at support@sketchpixy.com. We'll provide you with a SASS folder that works with fourseven:scss (there are some issues with fourseven not being able to load plain CSS files that we provide in the SASS folder currently). With this fix, your icons should load correctly.

As far as perfect-scrollbar.js is concerned, you need to ensure it loads in the <head> tag. This is necessary because Meteor, by default, doesn't load the scripts in order and always appends to the end of body tag. Take a look at the meteor-seed/server/setup-plugins.js file for how we Inject the scripts into the <head> tag.
Thanks for a prompt reply! Although, we are not using fourseven:scss package we use SASS package included by the theme. Do you maybe have any other potential issues on why the icons won't load. Originally we had a bootstrap theme and used font-awesome. When I tried using font-awesome in a rubix sidebar it worked but fontello won't load
Hi greem,

> Do you maybe have any other potential issues on why the icons won't load. Originally we had a bootstrap theme and used font-awesome. When I tried using font-awesome in a rubix sidebar it worked but fontello won't load

No idea about why it isn't loading without taking a look at your starter kit and how it is configured. Is it possible for you to send a copy to support@sketchpixy.com (without your business sensitive code) so we can take a look at it and see if we can reproduce the issue?
osilvaa PURCHASED
Hi,

How can I find the main-blessed.css files? I'm trying to use that with my datatables and I couldn't find it in the demo folder.

Thanks.
Hi osilvaa,

main-blessed.css files are generated when you compile for production. During development, these styles are loaded into a <style> tag within the <head> tag.

Any reason why you need the main-blessed.css file for datatables? The styles for datatables should be loaded automatically for you.
Hi,

You wrote 6 months ago that you'd have a typescript definition for rubix-bootstrap, it was supposed to be available for next minor release at the time.

Is this available now?

Thanks!
Greg
Hi Greg,

We'll be pushing out the typescript definitions along with upcoming release. We are currently working on the documentation/tutorials and should be done soon. Once that is ready we'll push out the release along with the type definitions.

Hope this helps :)
Fantastic, keep up the amazing work! And thanks for answering so quickly
Does this have latest webpack 2. I'm not looking into one that has gulp init to run tasks.
Hi bevikram,

4.1.0 has Webpack 1.0. Webpack 2 is scheduled for 4.3.0 release. The latest Rubix release does not use Gulp for building assets.

Hope this helps :)
manojch PURCHASED
Hi,

I need CRUD for Datatables,Can you please help me I've dropped a mail for the same at support@sketchpixy.com.

Regards,
Manoj.
Hi Manoj,

> I need CRUD for Datatables,Can you please help me I've dropped a mail for the same at support@sketchpixy.com.

Have replied to the mail received.
Running Redux GraphQL version:

I needed to install manually some libraries like babel-loader, babel-runtime and @skatchpixy/rubix. After that, i got my webpack running and asking me to browse for localhost:8080, but then i got no response on browser. Can you help me?
Hi tframesqui,

We have noticed that this happens mostly when the NodeJS version is < 6.x and NPM version is < 3.x. Can you provide the Node and NPM version:

$ node -v
$ npm -v

?
node -v
v7.7.3

λ npm -v
4.1.2
Hi tframesqui,

Looks like the "npm install" failed to finish for some reason. Is there an npm-debug.log file in your redux-seed folder?

If not, can you please run the following commands:

$ rm -rf node_modules

Install Yarn following this guide here: https://yarnpkg.com/lang/en/docs/install/ and then run:

$ yarn

And try again:

$ npm run dev -s
Hi,

I am trying to use Rubix chart . But my data is going to change dynmaically based on user action. So how do i use it?

In your demo app, you create a new instance inside 'componentDidMount' but theis will be run only once. Since the data changes, how do i update it?

Also other thing is, the x-axis data keeps sorting itself even if i specify the noSort option to true! This also results in the tooltip showing wrong label (it sorts data as well). My x-axis data is weekdays (Mon till sun) and due to this sorting, it puts them in random places! Why do we even need to sort it?

Regards,
Sathish
Hi Sathish,

> But my data is going to change dynmaically based on user action. So how do i use it? In your demo app, you create a new instance inside 'componentDidMount' but theis will be run only once. Since the data changes, how do i update it?

Just call the "addPoint({x, y})" or "updatePoint({x, y})" on your chart series to update the chart. An example of this is the Realtime Stacked Area chart that can be found in src/routes/AreaSeries.js file.

> Also other thing is, the x-axis data keeps sorting itself even if i specify the noSort option to true! This also results in the tooltip showing wrong label (it sorts data as well). My x-axis data is weekdays (Mon till sun) and due to this sorting, it puts them in random places! Why do we even need to sort it?

Can you let me know which chart type you are trying this on? If this is happening then this is definitely a bug. Can you please send the code to support@sketchpixy.com so we can reproduce this issue and figure out what is causing this.
Hi,

Alos how do i update the project to the latest version of rubix?

Regards,
Sathish
Hi Sathish,

> Alos how do i update the project to the latest version of rubix?

You can download the latest version of Rubix from your Wrapbootstrap dashboard. You would have also gotten an email from Wrapbootstrap with the download links. Then you can replace the "src" folder in the updated seed project with your own "src" folder.
Hi,

could you please provide an explanation how to turn off serverside rendering in the react/relay version?

Kind regards
Hi schmittr,

Sure. Please replace your server.babel.js file with this: https://gist.github.com/sketchpixy/67afe4b66db928892189ae2450a1c06f

It should disable server-side rendering.

Hope this helps :)
thanks a lot! :)
How do I persist the redux-persist state, or do I have any way to persist the state of the application?
How do I persist the state with redux-persist, or do I have any way to persist the state of the application?
Hi daniel-alves,

We will be including redux-persist in the upcoming release and have already provided it for a couple of our customers who requested for the integration. If you are interested hit us up at support@sketchpixy.com and we'll send you the integration.

Hope this helps :)
The company I work for has already bought the template, I should ask for this email or the email from my company.
Hi daniel-alves,

The company can send the mail. Make sure to also include the License ID of the purchase so we can verify before we send the download link.

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$20
5045Purchases

Licenses: Details »

Single application $20
Version:4.1.0
Type:
  • HTML Template
Bootstrap: Compatible with 3.3.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 9, 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: admin, bootstrap, dashboard, graphql, laravel, meteor, rails, reactjs, redux, relay
Item#:WB09498FH
Released:3 years ago
Updated:1 year ago
Sold exclusively on WrapBootstrap
sketchpixy

sketchpixy

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: