1482 comments

Hi,

We're building a React-based web app and are interested in using your template for the admin interface. Just to confirm, do you support deployment to Heroku?

Thanks
A simple Procfile with "web: NODE_ENV=production APP=app node launch.js" as the content is all that's required to get it to work on Heroku.
I deployed to heroku and it worked fine, but now when I update it it doesn't change. I tried "heroku restart" and that didn't help. Does anyone know what am I missing?
Hi kikocastro,

Did you try "gulp --rtl --production --name <app-name>" before pushing to Heroku?
that was the issue! I wasn't building for production. thx
Any news on the Ruby on Rails version?
Is there any way to buy this without paypal?
marclar PURCHASED
Hi, sketchpixy -- I sent an email, but in the interest of reaching you sooner (and possibly helping others), I put my questions about deployment to Heroku in a gist: https://gist.github.com/marclar/1d5df462271fe6e0b23c

Thank you,

Michael
The gulp-sass version should use the 1.3.3. Or it will failed in windows 7 environment.
rdnewman PURCHASED
In your ./src/global/vendor/bootstrap/sidebar_component.jsx under SidebarNavItem.handleClick, you have this function code:

handleClick: function(e) {
if(!this.props.href)
e.preventDefault();
e.stopPropagation();
this.emitOpen();
}

Without explicit braces, this is probably executed as

handleClick: function(e) {
if(!this.props.href) {
e.preventDefault();
}
e.stopPropagation();
this.emitOpen();
}

But I'm betting you meant this:

handleClick: function(e) {
if(!this.props.href) {
e.preventDefault();
e.stopPropagation();
}
this.emitOpen();
}

May not be an obvious bug out of the box, but when trying to customize your work to my own implementation it's worth being clear.
rdnewman PURCHASED
Sorry this comment system removed the code indentation that makes the issue more clear. But you have the actual code of course...
CumpsD PURCHASED
Any plans to update to React v0.13.1?
catlan PURCHASED
+1
nish PURCHASED
Hi,

Since react-bootstrap is trying to move away from jQuery dependency (which makes more sense and at the moment they only depend on jQuery when try to use tooltip and popover with overlay).

You have a lot of dependency on jQuery and unfortunately I'm not using jQuery in my web app that I am working on currently. For e.g in src/global/vendor/bootstrap folder in files like sidebar_component.jsx and panel.jsx. Is there any quick way I can run the react bootstrap component with using jQuery. What I would like to achieve is to have absolutely no jQuery dependencies for react-bootstrap jsx files under src/global/vendor/bootstrap folder.

P.S -> Brilliant theme and nice documentation. I would have loved the theme more without jQuery dependency though :)
Any pointers on how to make this theme work with Python + Flask? Thanks a lot!
kongu PURCHASED
Hello!

I have error during npm install

https://drive.google.com/file/d/0B3ZgjPkD_PwMZmpFQl9vRVJyMnM/view

How can I fix it?
NSLS PURCHASED
The installation on Windows is a real pain in the ass, i don't remember exactly, but it seems that i first did install node-sass by myself, then it required installing .NET Framework and after that i investigated that it also needs a Visual Studio installed, so i've downloaded a 2013 Express version and it worked, but i would rather suggest you to set up your local linux server, because it will become much much easier to manage with the nodejs plugins
Remarks
1) Live preview does not work form here but opens, if you go to http://rubix23.sketchpixy.com/ directly
2) Calendar/External events drop does not work in Chrom (does in Safari)
3) Alert boxes Hubspot Vertex show strange gray/white effect while opening
Neablis PURCHASED
Nice framework, a few questions.

1) Took me a long time to get it Reflux integrated with webpack, do you think that will be added by default sometime in the future?

2) Is there any documentation on the Rubix Charts? ATM i can only duplicate the demos and guess at it.
Is it possible to upgrade react & react-router to the latest version?
catlan PURCHASED
+1
catlan PURCHASED
Any change of an example with react-router "dynamic segment"? this.context.router.getCurrentParams() seems to be always undefined.
NSLS PURCHASED
I've experienced the same error, it seems that this is because of the outdated version of react-router and react itself, but after updating to the newer version template stops running, i will search for the solution and reply later about the results
NSLS PURCHASED
Found the solution.
The problem is, that you are trying to access the data via new functions of the new version of the React-Router, but since we only have an old version, you have to use the documentation for the old version too.
Simply, for this case, use
var Users = React.createClass({
mixins: [ ReactRouter.State ],
componentDidMount: function() {
var id = this.getParams().userID;
},
..
Works fine for me
catlan PURCHASED
Thx @NSLS
Don't buy. Even after purchase you will not get any response. Never seen a less responsive "team" for long.

Wasted $20
BTW: Better spend your money into 8 cups of coffee as mentioned above.
NSLS PURCHASED
The template itself is not bad, but already it is outdated and the developers don't care about responding to the questions according the template. If you are sure, that you can manage with the template based on React without any help - buy it for sure, but in other case - better look for some less complicated templates
Hi NSLS,

Sorry about the late reply. We get a lot of support tickets to our mail so we missed some of the comments here. We'll be updating React + React Router to the latest version by this weekend along with a major upgrade (we had to rewrite most of the bootstrap core because of changes in React's internals).
Hi there,

I wonder if this template includes PSD's as part of the downloadable pack. I could not find PSDs in the template.

Thanks
NSLS PURCHASED
Sorry to say, but it doesn't
Ops then how I should handle the design part? :(
MBINZAYED, did you get the psd files?
I'm getting an error installing.

During this bit:
package.json
Change directory to root of Rubix and run the following command (this launches the 'app' starter project) depending on your OS
environment:
cd path/to/rubix
$ npm install .
$ npm install -g gulp
$ gulp

I get an error stating: Bascially the error I get says: npm WARN package.json: No repository field and stops the installation.
Hi spudgun00,

I have replied to your email. Lets continue the discussion there. Thanks.
Hi there, I'm considering buying this template but reading through the comments I can see React is not the latest version. Is it going to be soon? Cheers.
Yes. We are almost done with the upgrades. So by tomorrow we'll be pushing out the update.
catlan PURCHASED
Any news on the update?
Hi catlan,

Like we said in the latest comment, we are writing the documentation for the changes which will take sometime because its a big update (includes Ruby on Rails native integration as well which is a separate documentation in itself). We have decided to release Rubix 3.0 itself rather than have one more minor update for React upgrade as the API has some significant changes due to us rewriting the bootstrap core.
Hi there,

Are you planing to update React to the last version 0.13.3?

I would like to integrate this template with react-bootstrap (https://github.com/react-bootstrap/react-bootstrap) via NPM instead of the bootstrap integration in the theme, is it possible?
I have replied to your email. Lets continue the discussion there. Thanks.

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$20
5043Purchases

Licenses: Details »

Single application $20
Version:4.1.0
Type:
  • HTML Template
Bootstrap: Compatible with 3.3.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 9, 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: admin, bootstrap, dashboard, graphql, laravel, meteor, rails, reactjs, redux, relay
Item#:WB09498FH
Released:3 years ago
Updated:1 year ago
Sold exclusively on WrapBootstrap
sketchpixy

sketchpixy

Signed up 3 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: