885 comments

Hi,

I didn't get an answer on my question from 2 weeks ago..

I'm studying the new angular2-final-seed version and I have a question about routing.
Where do you want us to register the new modules that need to load within the Layout, seems like you want us to use layout.routes.

But when I look at your example of Anotherpage module you use System.import instead of the child routing and module approach as is described on angular.io and by Victor Savkin.

If I create a new route and use system.import to point it to the module file of that module, I get a error that says it can not load that particular module. I tested the modules in a plain webpack + ng2 v1 setup and it works fine in those.

How do I need to resolve this, and for the future can you include better documentation, when you choose to use a different approach than best practice?

Thank you,

Roel
Hi!

We are sorry for the time it has taken to get the reply.
Thank you for the questions, yes, the documentation will be improved in the next release.
You may configure routing in the way that is better suited for your tasks and at your pleasure.
Could you, please, provide us more detailed information on the issues you have faced?

If you have any other questions, please, feel free to contact us on support@flatlogic.com.
Cheers!
heysatan PURCHASED
In the angular seed version, the Bootstrap styling doesn't work as expected. For instance adding the following markup to the dashboard does not style the label correctly:

<span class="label label-danger">Danger</span>

However, the buttons work fine.

<button class="btn btn-xs btn-success">Allow</button>

Can you help?
Hi!

Thanks for purchasing!

Sure, Angular 2 version uses bootstrap 4 which doesn't have 'label' class.
Please, check this Information on the Bootstrap 4.0 changes.
https://v4-alpha.getbootstrap.com/migration/#labels-badges-and-tags

If you have any other questions feel free to contact us on support@flatlogic.com.

Cheers!
mateogo PURCHASED
Hi!
I've found some sort of 'typing' problem when trying to upgrade from Typescript 2.0.0 to 2.0.2 or 2.0.3. Many errors arrised during startup compilation.
Could you give me directions to find a solution?
TIA

Excerpt from console, starting angular2-seed:
....
webpack: bundle is now VALID.
[default] Checking started in a separate process...
[default] Cannot find global type 'Boolean'.
[default] Cannot find global type 'IArguments'.
[default] /Users/mateogomezortega/Documents/Proyectos/Software/html5-templates/sing-toma2/angular2-seed/node_modules/@angular/core/src/facade/errors.d.ts:13:40
Cannot extend an interface 'Error'. Did you mean 'implements'?
[default] /Users/mateogomezortega/Documents/Proyectos/Software/html5-templates/sing-toma2/angular2-seed/node_modules/@angular/core/src/facade/lang.d.ts:10:20
Cannot find name 'Object'.
[default] /Users/mateogomezortega/Documents/Proyectos/Software/html5-templates/sing-toma2/angular2-seed/node_modules/@angular/core/src/facade/lang.d.ts:11:19
Cannot find name 'Array'.
[default] /Users/mateogomezortega/Documents/Proyectos/Software/html5-templates/sing-toma2/angular2-seed/node_modules/@angular/core/src/facade/lang.d.ts:14:11
Cannot find name 'DateConstructor'.
[default] /Users/mateogomezortega/Documents/Proyectos/Software/html5-templates/sing-toma2/angular2-seed/node_modules/@angular/core/src/facade/lang.d.ts:16:18
Cannot find name 'JSON'.
Hi!

Thank you for purchasing!

Yes, of course. The latest template's release supports typescript 2.0.0 version. So, unfortunately, any other typescript versions may cause issues.
We will keep typescript updated in our future releases.

If you have any other questions feel free to contact us on support@flatlogic.com.

Cheers!
kparsee PURCHASED
Hello. I'm having a very hard time using components I'm creating. Here's a very simple example:

featured-experience.component.ts:

import { Component, ViewEncapsulation } from '@angular/core';

@Component({
selector: 'featured-experiences',
templateUrl: './featured-experiences.template.html',
encapsulation: ViewEncapsulation.None
})
export class FeaturedExperiences {
}

featured-experience.module.ts:

import { CommonModule } from '@angular/common';
import { FormsModule } from '@angular/forms';
import { NgModule } from '@angular/core';
import { FeaturedExperiences } from './featured-experiences.component';

@NgModule({
declarations: [
FeaturedExperiences
],
imports: [
CommonModule,
FormsModule,
NgModule
]
})
export class FeaturedExperiencesModule {
}

featured-experience.template.html:
<div>
</div>

Here's the module definition for where I'm trying to use the featured-experience component:

import { CommonModule } from '@angular/common';
import { FormsModule } from '@angular/forms';
import { NgModule } from '@angular/core';
import { RouterModule } from '@angular/router';
import { HomePage } from './homePage.component';
import {FeaturedExperiencesModule} from '../featured-experiences/featured-experiences.module'
export const routes = [
{ path: '', component: HomePage, pathMatch: 'full' }
];

@NgModule({
declarations: [
HomePage
],
imports: [
CommonModule,
FormsModule,
RouterModule.forChild(routes),
FeaturedExperiencesModule,
]
})
export class HomePageModule {
static routes = routes;
}

Component definition of where I'm trying to use the component:

import { Component, ViewEncapsulation } from '@angular/core';


@Component({
selector: 'homePage',
templateUrl: './homePage.template.html'
})
export class HomePage {

}

Template HTML of where I'm trying to use the component:

<div class="container-fluid">
<main id="content" role="main">
<featured-experiences></featured-experiences>
</main>
</div>

I'm getting the following error:

Template parse errors: main.browser.ts: 25

I've also seen errors where it says it's not able to resolve the featured-experiences directive. Am I missing some type of configuration setting?

Thanks very much

Kian
kparsee PURCHASED
Sorry I wasn't clear; I'm using the latest angular2 seed template.
Hi!

It seems that after importing your module you've forgotten to add to declarations.

http://stackoverflow.com/questions/39062930/what-is-difference-between-declarations-providers-and-import-in-ngmodule

Cheers!
Hi, first of all congrats. for your great job on Sing App Template.

I am facing issues to build prod from npm. I have searched on the Web looking for a solution but all attempts failed.

Before sending this message I reviewed your README file and followed all required steps (I think!)

The error is:
command: npm run build:prod

ERROR in 5.1a9af9c3cbfdb154b6d4.chunk.js from UglifyJs
SyntaxError: Unexpected token: punc (.) [5.1a9af9c3cbfdb154b6d4.chunk.js:208,26]

npm -v
3.10.3

webpack 2.1.0-beta.22 ( I also tried with prior versions)

node -v
v6.7.0

Could you please guide me?

Thanks,
Hi, Thank you for your kind words!

Have you made any changes to the code before building? Some JS spelling error could cause this issue.

Also try to update everything: node, npm and webpack (even though they're pretty fresh).

We'll be waiting for your response, cheers!
Hi, yes I have included a new module (actually I copied your 'tables' and 'forms' code and changed some strings) and also included some http methods to consume an REST API ( long kick, here might reside the issue!)

I know the issue might be on my code (not yours) because your original package builds pretty well.

Do you have any idea how to track/trace this error to determine what piece of code is breaking?

Regards
Hi, I figured the issue out.

I added parsley localization :

import 'parsleyjs/dist/i18n/pt-br.js';

At first , instead of using the 'dist' version I used the 'src' version what was causing the error I reported.

Anyway, thanks a lot for your attention.
That's great you've figured it out!

Feel free to contact us if you have any other questions.

Good luck!
heysatan PURCHASED
Hi,

Awesome template!

I cannot get the NKDateTime to have the rich styles it does in the full Angular2 project in the seed project, the datepicker is not sizing correctly and is missing icons. Can you please help?

Thanks
Hi!

Thank you for purchasing!

Yes, of course. The problem is that angular2 seed version does not include ng2-datetime npm module, that is why you can face some issues.

If you have any other questions feel free to contact us on support@flatlogic.com.

Cheers!
heysatan PURCHASED
Hi,

Thanks for your reply. Even when that npm package is added, and the NKDateTime module included, the pop up date picker does not style correctly - you can quickly test this by adding it to the seed project. I think you may have added some extra SASS variables. If so, can you please point me to them so I can get it looking at good as the Angular2 project :)

Thanks for the great support,
H
Have you included the module styles
(elements.style.scss file in angular 2 version)?

@import "../../../../node_modules/ng2-datetime/src/vendor/bootstrap-datepicker/bootstrap-datepicker3.min";
@import "../../../../node_modules/ng2-datetime/src/vendor/bootstrap-timepicker/bootstrap-timepicker.min";
artemano PURCHASED
I'm going to check once again and will let you know if that works. thank you.
Pl help in installing jquery.flot.animator.

when I copy the napa: {.....}

section into my seed package.json and run npm install

it does not install any of the components listed there. Could you pl help install those.
Hi!

jquery.flot.animator in not an npm module, you should either add it's scripts yourself or (and that would be better) find some other module.

Cheers!
Hello,
I just bought the singApp, and I have some doubts.

Do you have any data to release the version with rails? Rails will be 5?
When this version out I'll get right to it without making a new purchase?

I'll try to make this integration myself, but it would be nice if there is already a beta thing to start and even so I can contribute to this integration.

There is some sort of communication channel beyond this page in WrapBootstrap? Email, Slack, Telegram, something more dynamic.

Congratulations for the work.
Hi,

We have answered via email.

If you have any other questions feel free to contact us on support@flatlogic.com.

Cheers!
Inger PURCHASED
Hi,

We need to know when a new version wiil be released. We are planing to migrate the app and we want to start using the new version without the issues puted here for others customers.

Other point, do you have a documentation or an scritp to use internacionalization with angular2 and bootstratp? In the future sing will be migrated for a model with internacionalization?

Thanks

Inger
Hi, Inger!

We are glad you are interested in our theme!

For the moment we are working on the new version to get all the reported issues fixed. Unfortunately, the new release date has not yet been set. We are focused on this and have not planned internationalization yet, but thank you for the question, we will think it over.

If you have any other questions, please, feel free to contact us on support@flatlogic.com.

Cheers!
Hi,

We have to purchase http://demo.flatlogic.com/sing-wrapbootstrap-3.3.0/angular/#/app/dashboard this theme but from its source it seems like it is developed in older version of angularjs but we are looking for a theme developed with angular js 2. so we are little confused if it developed in angularjs 2 or not.
Hi, Commando!

We are glad you are interested in our theme!

The Sing 3.3.0 version includes angular2 package which supports Angular 2.0 Final Release.

If you have any other questions, please, feel free to contact us on support@flatlogic.com.
Cheers!
Hi,I purchased the project but how can i run it in my local machine.I installed npm in angular2 folder but it shows error in console.Can you provide a good document to go ahead.
Hi,I purchased the project but how can i run it in my local machine.I installed npm in angular2 folder but it shows error in console.Can you provide a good document to go ahead.
Hi!

Thanks for purchasing!

Sure, please, have a look at the documentation, "Running the project" section, we hope you will find it useful.
If it doesn't help feel free to send us your error message on support@flatlogic.com.

Cheers!
Hi!
I don't see a select2 with multuple choice example in the Angular2 version, although it is present in the demo on the website. How can I implement it?
Thanks!
Hi!

You can see a multiple select example in the form wizard popup's service selection tab.
You can find the code is in the wizard.template.html file.

If you have any other questions feel free to contact us on support@flatlogic.com.
Cheers!
Hi,can you please tell me where is the documentation for the project.
Hi!

For some reason, we can't see the 'purchased' label next to your name.
If you have bought the theme, the documentation resides in the 'Documentation' folder of the package.

Cheers!
I upgrade from template version 1.0.0 to 3.0.0,
Now i have many errors of compile typescript in vs2015.
version 1.0.0 i thing i can use typing,
but version 3.0.0 not using.
==>version angular 2.0.0
Hi,

We use WebStorm and Sublime internally for frontend development.
You can follow the Sing documentation for installing and running the template on your OS, after that you can edit it's code in the IDE that fits you best.

If you have any other questions, please, feel free to contact us on support@flatlogic.com.
Cheers!
Has anyone gotten the angular2-seed project to work in Visual Studio? I have tried a handful of different tutorials and gotten nowhere
Hi!

We use WebStorm and Sublime internally for frontend development.
You can follow the Sing documentation for installing and running the template on your OS, after that you can edit it's code in the IDE that fits you best.

If you have any other questions, please, feel free to contact us on support@flatlogic.com.
Cheers!
gabonleon PURCHASED
I have sing 3.2 and see update 3.3
I download updated sing 3.3, but download too slow, and always failed after 8 hours, bout 3 days trying

Please help
Hello!
Thanks for purchasing!

If you have not yet managed to download the 3.3. update, please, contact us on ​support@flatlogic.com.
thehodge PURCHASED
Hey do you have any ETA on the rails application?
Hi!
Thanks for purchasing!

Please, contact us on ​support@flatlogic.com.

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
3462Purchases

Licenses: Details »

Single application $24
Version:3.8.0
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: angular, angular4, bootstrap4, bower, html5, react, retina, sass, seed, web app
Item#:WB0J6BJ85
Released:2 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
okendoken

okendoken

Signed up 4 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: