885 comments

anavgale PURCHASED
Hai,
Does file uploader provided in the form elements works.
Can it be used to to upload files to server.
Hi!

It should be easily configured to work with your server.

If you have any other questions, plaese, contact us on support@flatlogic.com.
Cheers!
I have sent you an email to you as you want.
anavgale PURCHASED
@rvdhabhi I didn't received any email.
Anavgale, Rvdabhi just replied the wrong comment.He sent email to the customer support, as we had asked =)
I am trying to implement apache configuration to run theme directly on apache server, added "apache-server-configs": "^2.14.0", package to package.json but it wont work and given unmet dependency error, please help.
Hi!

Are you using Angular 2 version?
Please, send us the errors screenshot on support@flatlogic.com.
Thanks!

Cheers!
I have sent you an email to you as you want.
Thanks for the patience!
Hi,

I'm interested in Sing App - Web & Angular 2.0 Dashboard. Now If I purchased it do I have to know angular 2 well to customize it or knowing having good knowledge in webdesign is enough? Our developers use PHP laravel framework -- which will be fine i think.
So this is a typescript complied version? ------- you know what I'm asking..
Hi! We are glad you are intrested in our theme!

No, you don't have to master angular 2 to customize the theme. There is a number of examples.
Anyway, feel free to contact us if you face any trouble.

Yes, we use Typescript for the Sing.

Cheers!
anavgale PURCHASED
[(ngModel)] not working if I use data-mask on Input elements.
How can it work.
Have a look at the link, hope you will find it useful.
http://stackoverflow.com/questions/37800841/input-mask-fields-in-angular2-forms

​Cheers!
anavgale PURCHASED
Link is not so helpful. In the code you have provided data mask to input elements. How ever, data mask is working fine, but why [(ngModel)] is not updated, which works perfect if data-mask is not used.
Sorry for that, it seems to be a bug, we'll fix it in the next release.
​For now, please, try to use some other libs for input masks, for example https://www.npmjs.com/package/angular2-text-mask.

Thanks for your patience!
Cheers!
anavgale PURCHASED
Few more bugs detected for data-mask field.
It doesn't work at all. while browsing page on android device (tested on mobile).

Also results unexpected keyboard behaviour, (page hangs and continueously blinks) on ios device (tested on tab).
anavgale PURCHASED
Dis you really tested all components ? Or do we need to implement/use any other package to view the pages in mobile devices & tabs ?
Thanks a lot! Could you, please, provide us with the details (android\ios versions) on support@flatlogic.com?

Yes, we tested, but still, we have a huge collection of components, thus some issues may occur.

Cheers!
Hi,
How can I get a refund? I purchased this template because you advertise the Angular 2 full version, great documentation, best practices and a framework to boost development and couldn't find any of those, after wasting more than 2 days trying to clean the template and reuse something I gave up. The docs needs an update, the components styling is not encapsulated.
Don't get me wrong this templates is good if you want to use jquerys approach but doesn't follow the best practices of Angular 2.
Hi!

All the key components are built according to the best practices.
There is a number of the Sing users and the theme versions for them, as well as the usercases where many components are to be changed during the integration process.
Please, provide us your particular recommendations on the documentation and the other troubles you have faced.
If you have any other questions, please, contact us on support@flatlogic.com.
Cheers!
angular_boss
Hi :) ,

same issue, my client bought yesterday Sing App, but it doens't include angular2 full version, it's

mistake or it must be so?

Best Regards Maksym.
Hi!

Yep, there must be a mistake.
Please, tell the client he can contact us on support@flatlogic.com. We will sort it out.

Cheers!
angular_boss
it's possible to include angular 2 full version?
What do you mean by "including" angular2 version?
Please, contact us on support@flatlogic.com.
anavgale PURCHASED
Where is the code for select (multiselect) dropdown. Can you provide exact code for multi select dropdown element with search enabled.
Hi!Thanks for purchasing!

You can find different select inputs on Forms -> Form Elements page. Multi select dropdown with search field you can check on Forms -> Form Wizard page (click 'Launch Wizard' button and go to 'Service Selection' tab).

​Cheers!
anavgale PURCHASED
Thanks.
Were you able to make it work? What dependencies does it need? The major problem with sing template is that with each component, the dependencies are not listed and you end up spending hours or days figuring out what to include in the project. Wish they would document that, it will take minutes per component when they are adding it.

I guess this is the code, but it all comes up garbled in my page. I have select2 included

<div class="wizard-input-section">
<p>
Please choose the services you'd like Panopta to
monitor. Any service you select will be given a default
check frequency of 1 minute.
</p>

<select name="services" data-placeholder="Service List" style="width:350px;" data-theme="bootstrap" class="select2 create-server-service-list form-control" multiple>

<option value=""></option>
<optgroup label="Basic">
<option selected value="icmp.ping">Ping</option>
<option selected value="tcp.ssh">SSH</option>
<option value="tcp.ftp">FTP</option>
</optgroup>
<optgroup label="Web">
<option selected value="tcp.http">HTTP</option>
<option value="tcp.https">HTTP (Secure)</option>
<option value="tcp.dns">DNS</option>
</optgroup>
<optgroup label="Email">
<option value="tcp.pop">POP</option>
<option value="tcp.imap">IMAP</option>
<option value="tcp.smtp">SMTP</option>
<option value="tcp.pops">POP (Secure)</option>
<option value="tcp.imaps">IMAP (Secure)</option>
<option value="tcp.smtps">SMTP (Secure)</option>
<option value="tcp.http.exchange">Microsoft Exchange</option>
</optgroup>
<optgroup label="Databases">
<option value="tcp.mysql">MySQL</option>
<option value="tcp.postgres">PostgreSQL</option>
<option value="tcp.mssql">Microsoft SQL Server</option>
</optgroup>
</select>
</div>
</div>
Sauverma16, I see what you mean, thanks for the feedback!
Answering your question on the dependencies - Select2 jquery plugin is needed.

Cheers!
upmauro PURCHASED
Missing form element like

https://jqueryui.com/spinner/

:(
Hi!

I see, we will add it in the next release.

Cheers!
Hi
I bought this template and i try to integrate it in my meteor-angular application with no success.
Please do you have any steps i have to follow to use your this template in meteor-angular ?
I really need help

You can clone the meteor app from this link https://github.com/urigo/angular2-meteor-base

If anybody have any experience with meteor-angular and this template , please share with me.

Regards
Hi! Thanks for purchasing!

Unfortunately, we don't have a guide for meteor-angular at the moment, we are sorry.
We will make it as soon as we get enough expertise.

Thanks for patience and If there is any other thing we can help you with, please, contact us on support@flatlogic.com.
Cheers!
What version of Angular 2 is currently being used? Also in the Angular 2 version is Bootstrap 4 being used? I'd like to know the answer to these questions before I purchase. Thanks!
Hi, we are glad you are interested in the Sing!

Yes, the current version of Angular is 2.0.0.
Yes, Bootstrap 4.0.0 is used in Angular 2 =)

Cheers!
Inger PURCHASED
Hi,

When will be released a new version?
Hi!

We work on the Sing update at the moment, but, unfortunately we have not managed to set the release date yet.

If you have any other questions, please, feel free to contact us on support@flatlogic.com.
Cheers!
In the download for 3.3.0, the code for multiple-select is missing in form elements.This is there in your preview but missing from download. Could you pl provide code for that.
Hi!

You can see a multiple select example in the form wizard popup's service selection tab.
You can find the code is in the wizard.template.html file.

If you have any other questions feel free to contact us on support@flatlogic.com.
Cheers!
rvwv PURCHASED
I'd like to say that the support Isn't doing proper job answering the mails...
I have tried to contact support several times.. more then 2 weeks passed but no answer yet(multiple emails).

There is issues with Angular 2 seed project... and angular 2 full project.
Here is a photo showing seed project navigation .... http://imgur.com/QDc49Um
this issue happens after i enter sub navigation and then hit return.

Big issue with build:prod Why there is no optimizations? treeshaking,uglify?gzip??
Please contact me and stop ignoring emails on support.
Hi!

Thank you for the comment!
We are a bit surprised to hear that, because we usually answer emails asap. Obviously, there are cases/issues we have to forward(it may take a couple of days to get the answer from the developers), but, generally, we answer emails together with the wrapbootstrap comments, you can see the progress here.
We have checked all the tickets for the period, but, unfortunately, have not managed to find a letter describing you problem. Have you sent it on support@flatlogic.com?
Please, write to us again and, please, indicate the time/date of your previous letter for us to investigate the situation. Thank you.
The question about navigation - we can't reproduce it.
The build issue - that is what we are focusing on at the moment, it will be added in the future releases.

Thanks for the patience!
Cheers!
in the form > element there is no multi-select option. the preview does not match the downloaded app on this part.

Please check
Hi Alitawasha!

Thanks for purchasing!

You can find different select inputs on Forms -> Form Elements page. You can check multi select dropdown with search field on Forms -> Form Wizard page (click 'Launch Wizard' button and go to 'Service Selection' tab).

If you have any other questions, please, contact us on support@flatlogic.com.
Cheers!
​Cheers!
TiagoReis PURCHASED
The Angular 2 full version is not working!

Windows 10 Professional
node version: 7.1.0
npm version: 4.0.2
node-sass version: 3.9.3

They're all the latest versions.

It's failing here:

npm ERR! node-sass@3.9.3 postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-sass@3.9.3 postinstall script 'node scripts/build.js'.

Please check ASAP.
Hi TiagoReis!

Thanks for purchasing!

There can be a node installation error. Please, check the link https://github.com/sass/node-sass/issues/1581, hope you will find it helpful.

If you have any other questions, please, contact us on support@flatlogic.com.
Cheers!
dmastag PURCHASED
Same problem here

Windows 10
node v7.2.0
npm 4.0.2
node-sass 3.13.0 (Wrapper) [JavaScript]
libsass 3.3.6 (Sass Compiler) [C/C++]

I was looking at that link but have no clue what i should be doing.
TiagoReis PURCHASED
It didn't help. Please provide specific actions to take, to fix it. Thanks.
Hi, Dmastag and TiagoReis!

The issue is that you use node 7+. Please, downgrade to node 6.x and npm 3.x for now while we will be fixing the problem.
Also, make sure you have installed Visual C++ Build Tools.

​Cheers!
Is there a way to change the yellow color of the menu icons? Also is there a way to change the theme color?
Hi, Anigeorge!

If you're talking about sidebar's yellow desktop icon you should change it's .icon wrapper 'background-color' to any color you prefer and the inner's <i> elements 'color' to some other color. You can change theme's color by changing it's sass files.

Cheers!
Hello Guys

Thanks for your one of the best work and best template i used for angular 2.

I have some small issue in Development mode once template load by default
toggleSidebar('static') so menu is visible once page load but when i build same apps for production now by default menu is toggleSidebar('collapse') i think. You may check below link it default template i just build it for production so please help me display by default static menu.

http://nkjsv.com/visualserver/test/#/app/dashboard

Thanks
Navin
Hi, Navin!

Let us, please, pass your question to the development team to have closer a look. We will update you asap, but it may take some time. Thanks for the patience!

For now, as you're using angular 2 version, you can try changing app.config.ts file. Also, you could try changing ''nav-static" field the config object. Please, try it and tell us on support@flatlogic.com if it helps.

Cheers!
anavgale PURCHASED
hello.... in the grid section the grids size changes depending upon the text inside them can we make the sections static so that their size remain same all the time.
Hi!
Yes, please, try to set those element's width to some predefined size in sass files.
Evosys PURCHASED
Hi,

How do I sign out on mobile ? The gear disappear, it's not great. I would like to add something in this menu like changing language but if it's not there in mobile screen size, it's not very useful.
Hi Evosys!

Yes, it disappears on mobile. You can duplicate the buttons you need in the sidebar and make them visible on mobile only.

​Cheers!

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
3463Purchases

Licenses: Details »

Single application $24
Version:3.8.0
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: angular, angular4, bootstrap4, bower, html5, react, retina, sass, seed, web app
Item#:WB0J6BJ85
Released:2 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
okendoken

okendoken

Signed up 4 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: