885 comments

Hi, I would like to know few things before buying this theme.
I want a theme
1. developed in Angular 2 or higher, and bootstrap 4

if it has Angular 2 + bootstrap 4, can you show app directory structure.
or is it developed in Angular-cli ? calling JSON file URLs as API to get and populate date in components.

cause I am more concern with structure and data sharing among components.
As I customer, I can say that on version 3.4.0, about Angular 2, there are two projects/folters: angular2 (that has all the features seen on the online demo) and angular2-seed (that has just a few basic things).
Most of the data are hard-coded as array on the typescripts files. I didn't see examples of calling api urls but it's pretty easy, something like

get_dashboard(): Observable<any> {
let output$ = this.http
.get(GlobalConsts.BASE_API_URL+'/api/common/dashboard?access_token=' + this.cookieService.get('access_token'))
.map(result => {
return result.json().data;}
)
//.catch(this.handleError())
;

return output$;
}
Hello Kaleemullah360!

I'm really sorry we've kept you waiting, thank you for the patience!

We don't use remote apis, sometimes we has hardcoded data, sometimes we keep it in separate files.
We don't use angular cli (we use just webpack + angular 2).

And there is the app structure: http://imgh.us/0001_2.png

Have a good day!
Hi. Do you have some installation guide for Visual Studio 2015 .NET Core project?
For Angular 2
Hello Syalex!

Unfortunately, we don't have any installation guides for the Visual Studio 2015 .NET Core at the moment. So sorry for this inconvenience!

Have a wonderful day!
Hello. Do you provide free upgrades for existing customers? I've purchased it some months ago (4 or 5) and I would like to receive improvements or bug fixes. Thanks.
Never mind, I received it. Thanks
have been sending message via github support page, guess you won't respond there.

have some issues with Angular2 version:

[root@localhost sing-wrapbootstrap-3.4.0]# cd angular2
[root@localhost angular2]# npm install
npm WARN lifecycle Sing@3.4.0~install: cannot run in wd %s %s (wd=%s) Sing@3.4.0 napa /root/horizon/sing-wrapbootstrap-3.4.0/angular2
Sing@3.4.0 /root/horizon/sing-wrapbootstrap-3.4.0/angular2
+-- UNMET PEER DEPENDENCY @angular/common@2.4.1
+-- UNMET PEER DEPENDENCY @angular/compiler@2.4.1
+-- UNMET PEER DEPENDENCY @angular/core@2.4.9
+-- UNMET PEER DEPENDENCY @angular/forms@2.4.1
+-- UNMET PEER DEPENDENCY webpack@2.2.0-rc.2

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^1.0.0 (node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN @angular/common@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/compiler@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/compiler-cli@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/forms@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/http@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/platform-browser@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/platform-browser-dynamic@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/platform-server@2.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN @angular/router@3.4.1 requires a peer of @angular/core@2.4.1 but none was installed.
npm WARN codelyzer@1.0.0-beta.4 requires a peer of @angular/compiler@~2.2.0 but none was installed.
npm WARN codelyzer@1.0.0-beta.4 requires a peer of @angular/core@~2.2.0 but none was installed.
npm WARN ng2-table@1.3.2 requires a peer of @angular/common@~2.0.0 but none was installed.
npm WARN ng2-table@1.3.2 requires a peer of @angular/compiler@~2.0.0 but none was installed.
npm WARN ng2-table@1.3.2 requires a peer of @angular/core@~2.0.0 but none was installed.
npm WARN ng2-table@1.3.2 requires a peer of @angular/forms@~2.0.0 but none was installed.
npm WARN sass-loader@4.1.0 requires a peer of webpack@^1.12.6 || ^2.1.0-beta but none was installed.
npm WARN string-replace-loader@1.0.5 requires a peer of webpack@1 || 2 || ^2.0.0-beta || ^2.1.0-beta but none was installed.
npm WARN webpack-dev-middleware@1.6.1 requires a peer of webpack@1 || ^2.1.0-beta but none was installed.
npm WARN Sing@3.4.0 No repository field.
npm WARN Sing@3.4.0 No license field.
npm ERR! code 1

[root@localhost angular2]# node -v
v6.10.0
[root@localhost angular2]# npm -v
3.10.10
[root@localhost angular2]#

Do you have any idea what has gone wrong? tried a few version of Node, same problem.
Hey Zhenqidong!

You can disregard the WARN messages, it is ok to have some of them.
Also, you have the outdated versions of node and npm, could you try to update both to the latest stable versions?

Tell us, please, if it helps,
Cheers!
what is the suggested version of node and npm?
Hello,

The 7.7.2 version is for node, and the 4.4.1 version is for npm.

Cheers!
I want to buy this theme, but have couple of questions:
- Does this have build scripts included like how to build for production by concate, minify, uglify code?
- Is it based on webpack and TypeScript?
- Does it support any coutry Map as it is showing in Dashboard?
- Does it has placeholders for e2e test cases as well?

Thanks!!
Hello,

We are glad to hear you are interested in the Sing!

Yes, the theme is based on webpack and typescript.
Yes, it has dev and prod builds available.

As for the map, we used https://github.com/neveldo/jQuery-Mapael for that, you can check the link out and look through its feats.

Cheers!
Hello
I have just purchased the latest version, and for me, it's great.
the question is:
I want to use the hierarchical tree of files as is , even in prod mode
I use apache as server side.
Thanks
Hello,

I'm sorry, could you clarify your question, please?
Do you want to have separate js files (instead of a single bundle) even in prod mode?

Looking forward to hearing from you!
Can you add a front landing page that includes a pricing section to your theme? It would be extremely useful and more people would definitely buy.
Hello,

Thank you for the feedback, we really appreciate your suggestion and we will discuss it with the team!

Have a wonderful day!
Hi guys,

I love the template you created, it looks and works nice. I purchased in January. I am using the Angular 2 version. Everything is running fine, but I am struggling tu use the angular cli - is there anything missing?

after npm install angular-cli the bash throws out some warnings, ... but when i want to use ng g component test it says:
$ ng g module test
As a forewarning, we are moving the CLI npm package to "@angular/cli" with the next release,
which will only support Node 6.9 and greater. This package will be officially deprecated
shortly after.

To disable this warning use "ng set --global warnings.packageDeprecation=false".

You have to be inside an angular-cli project in order to use the generate command.

$ npm version
{ Sing: '3.4.0',
npm: '4.4.1',
ares: '1.10.1-DEV',
cldr: '30.0.3',
http_parser: '2.7.0',
icu: '58.2',
modules: '51',
node: '7.7.2',
openssl: '1.0.2k',
tz: '2016j',
unicode: '9.0',
uv: '1.11.0',
v8: '5.5.372.41',
zlib: '1.2.11' }

thanks for the help
Hello,

Unfortunately, we don't have the required expertise in cli, our theme doesn't support it at the moment. So sorry for this inconvenience!

Thank you for the patience,
Cheers!
Hello from Colombia,

Are they using Angular-Cli?
Hello Ronald,

Currently we are using web pack without angular cli :)

Cheers from the heart of Belarus!
kiranbm PURCHASED
Hi

I have purchased this theme and theme works great. But I am having one issue of "Sidebar Menu Overlapping" in the theme. Can you please let me know the fix for it?

Steps to generate the issue -

http://demo.flatlogic.com/sing-wrapbootstrap-3.4.0/angular/#/app/form/elements

If you simply change the url to "http://demo.flatlogic.com/sing-wrapbootstrap-3.4.0/angular/#/app/form/validation"

Then check the sidebar - menubar should be overlapping
Hello,

Thank you for your kind words and the feedback, we will check that out!

Cheers!
Hi, it is asked earlier in January, but when will you guys upgrade Bootstrap4 from alpha5 to a newer version. I'm encountering styling issues with plugins because they are styled with a newer version.
If I upgrade your theme to a newer Bootstrap, it fails.
Hello,

We are working on it at the moment, will be available in the nearest release,
Thank you for the patience!

Cheers!
Estoy interesado por el producto, pero, ¿dónde encuentro manuales, tutoriales de como instalarlo y como usarlo...?

Gracias!!!
Hello,

Could you contct us on support@flatlogic.com, please? Thank you!
Can we update to Angular 4 or it is not compatible with the rest of the code?
Hello,

Unfortunately, we have not tried updating it, so we cannot provide you this information at the moment.
I'm sorry for this inconvenience.

Have a good day!
Hi!

Any plans to update to angular 4? It seems to be quite straightforward and performance improvements are great. What about AOT?

Thanks for your work!
Hello!

We'll move to angular 4 in future releases.
As for your second question, unfortunately, we don't have any exact plans on AOT at the moment.

Thank you,
Cheers!
Hi!
Can tell me when will you guys release React version?
Hello,

We will release the react-seed version of the Sing soon,

Thank you for the patience,
Cheers!
Hi, how are you, you guys do an excellent job, I've tried many templates and the design that you have is maginifico and it goes very fast.

I have many questions, I hope you can answer:
Because having installed

Visual C ++ Build Tools.

Python 2.7

Why have not they migrated to angular-cli?

Now you can build some tutos to add new component?

Thank you .. and congratulate you for this great work.
Hello,

Thank you for your kind words, we will keep improving Sing in future releases!

As for your questions, Angular cli just isn't the tool of our choice right now :)
Unfortunately, we don't provide any tutorials on adding new components at the moment, but in the source code it is quite straightforward.

Cheers!
Hi Guys, someone get "Check Erros" popup and fix it ?
Hello,

We will check it,

Have a wonderful weekend!
I like your template and I am happy to use it, but its heavy jQuery usage is giving me hard time for prerendering (do you have any plan to remove/reduce jQuery usage in Component and Directives ?
Hello,

We are reducing JQ usage in each and every release, doing it step by step,
Sorry it takes time, thank you for your patience :)

Cheers!
Hi, do you provide the Angular 2 seed and full with Typescript or javascript? Do you have Typescript support?
Hello,

Our Angular2 and Angular2-seed versions come with Typescript.
If you have any questions, feel free to reach us on support@flatlogic.com.

Have a wonderful week!
tororog PURCHASED
Morris chart with Sing App works well, but when I changed data(using morris option variable), it didn’t show new data. As I checked morris chart’s document, it has setdata function to reload new data. I created setdata function in morris chart directive to refresh, and tried to do that by this way - http://stackoverflow.com/questions/40438486/calling-function-in-directive. But it didn’t work. It did nothing. How can I redraw from new data with morris chart?

// setData function in morris.directive
setData(data): void {
window['Morris'][this.capitalise(this.type)].setData(data);
}

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
3462Purchases

Licenses: Details »

Single application $24
Version:3.8.0
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: angular, angular4, bootstrap4, bower, html5, react, retina, sass, seed, web app
Item#:WB0J6BJ85
Released:2 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
okendoken

okendoken

Signed up 4 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: