885 comments

After installing the following programs node, bower, gulp ( global ) I get the following eror when I run npm install in Angular 2 version:

npm ERR! git clone --template=/Users/ralarcon/.npm/_git-remotes/_templates --mirror git://github.com/HubSpot/pace.git /Users/ralarcon/.npm/_git-remotes/git-github-com-HubSpot-pace-git-v0-7-7-6a6dbbcd: Cloning into bare repository '/Users/ralarcon/.npm/_git-remotes/git-github-com-HubSpot-pace-git-v0-7-7-6a6dbbcd'...
npm ERR! git clone --template=/Users/ralarcon/.npm/_git-remotes/_templates --mirror git://github.com/HubSpot/pace.git /Users/ralarcon/.npm/_git-remotes/git-github-com-HubSpot-pace-git-v0-7-7-6a6dbbcd: fatal: unable to connect to github.com:
npm ERR! git clone --template=/Users/ralarcon/.npm/_git-remotes/_templates --mirror git://github.com/HubSpot/pace.git /Users/ralarcon/.npm/_git-remotes/git-github-com-HubSpot-pace-git-v0-7-7-6a6dbbcd: github.com[0: 192.30.253.112]: errno=Connection refused
npm ERR! git clone --template=/Users/ralarcon/.npm/_git-remotes/_templates --mirror git://github.com/HubSpot/pace.git /Users/ralarcon/.npm/_git-remotes/git-github-com-HubSpot-pace-git-v0-7-7-6a6dbbcd: github.com[1: 192.30.253.113]: errno=Connection refused
npm ERR! Darwin 16.4.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
npm ERR! node v6.10.2
npm ERR! npm v3.10.10
npm ERR! code 128

npm ERR! Command failed: git clone --template=/Users/ralarcon/.npm/_git-remotes/_templates --mirror git://github.com/HubSpot/pace.git /Users/ralarcon/.npm/_git-remotes/git-github-com-HubSpot-pace-git-v0-7-7-6a6dbbcd
npm ERR! Cloning into bare repository '/Users/ralarcon/.npm/_git-remotes/git-github-com-HubSpot-pace-git-v0-7-7-6a6dbbcd'...
npm ERR! fatal: unable to connect to github.com:
npm ERR! github.com[0: 192.30.253.112]: errno=Connection refused
npm ERR! github.com[1: 192.30.253.113]: errno=Connection refused
npm ERR!
npm ERR!
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR! /Users/ralarcon/Documents/sing-wrapbootstrap-3.6.0/angular4-seed/npm-debug.log
----- fix bug --- i had problem with the firewall of my company
Hello,

Well done, we are glad to hear you've managed to fix it.
Also, you can update node and npm, it seems you have slightly outdated versions installed.

Cheers!
Hi,

With the new release, I see the following warnings. Hope there is nothing to worry for now?
Also, can you suggest the Dockerfile content to put this in Docker container?

Thanks in advance.
Hello,

Correct, it may give you warnings, there is nothing to worry about.
As for your second question, we haven't tried docker unfortunately.

Cheers!
Hey guys,

I bought this and I wrote to you in hopes of getting a kind of step by step to replicate the dashboard, I cant use the seed project as I work on ASP.net Core with NG4, so getting from seed its a no go. I was wondering if you have at least a basic step by step on how to get the dashboard look and then I will keep working on my own to expand it.

I wrote to your email twice 1 week ago and still have not gotten response.
Hello,

We apologize for the wait, we have just answered your email one more time.

Also, in the case you are looking to use the components from the full version, the better way around is to use the full version and remove all the components and deps you won't use.

Looking forward to hear from you,
Cheers!
Hello, I recently purchased. Sing App - Web & Angular 4.0 Dashboard 3.6.0

I am using angular4. Trying to install it on Linux box and running into below error while running command, npm start

ERROR in ./src/app/forms/forms.module.ts
Module not found: Error: Can't resolve 'twitter-bootstrap-wizard/jquery.bootstrap.wizard.js' in '/var/www/html/sing/angular4/src/app/forms'
@ ./src/app/forms/forms.module.ts 16:0-62
@ ./src/app/layout/layout.routes.ts
@ ./src/app/layout/layout.module.ts
@ ./src/app/app.routes.ts
@ ./src/app/app.module.ts
@ ./src/app/index.ts
@ ./src/main.browser.ts
@ multi main
never mind on above. I got it sorted out.
Hello,

We are glad to hear you have managed to sort it out,

We apologize for the wait and the delay in coming back to you, we had public holidays,
Cheers
Hello,
I recently purchased. Sing App - Web & Angular 4.0 Dashboard 3.6.0
I am using "ajax-bootstrap4".
Trying to change that height's length of calendar on mobile view.
But, I couldn't do that.
which source code should I change it?
Hello,

Thanks for purchasing!

Check out _custom-ibs-override.scss and _widgets.scss files for calendar styles.

Cheers!
I am trying to run "angular4-seed" project using "npm run server:prod". My goal is to run it at port 80. I changed webpack.prod.js file's line to have port 80 in there.

const PORT = process.env.PORT || 80;

However, whenever I run the project using npm run server:prod, it's always running on port 8080 or 8081.

Any thoughts on what I am doing wrong here, how can I run prod run on port 80
Hello,

Try to check package.json file, there is a line: "server:prod": "http-server dist --cors"
Please, add change it to "server:prod": "http-server dist --cors -p X", where X is the port you need :)

Have a good day!
Hi guys,

So I have been using this for a couple of weeks (mostly integrating it with asp.net core). I like the dashboard but I have found one issue that is serious in my opinion.

If we try to use 2 way binding using the [(ngModel)] it doesnt load the component at all, It gives an error on the console like this:

Error: Uncaught (in promise): Error: Template parse errors: Can't bind to 'NgModel' since it isn't a known property of 'input'.

Do you guys have a special way to bind it on the dashboard?
Hello,

It seems to be the particular custom code problems, we do not support custom implementations at the moment so we cannot figure it out for you, unfortunately :)

Cheers!
zeko77 PURCHASED
Hi. Any chance on supporting Aurelia?
Hello,

No, we don't have any exact plans on supporting Aurelia at the moment,
Cheers!
roleeks PURCHASED
Hello!

Everything works fine but I have question about Select2 (multiselect) example, there is example in the demo but I can't find any example in 3.6.0 version.
Hello,

Check out this repo https://github.com/NejcZdovc/ng2-select2

Have a wonderful weekend!
Is there a way to use angular-cli?
Hello,

We don't support angular-cli at the moment,

Cheers!
I'm a newbie to webpack and am trying to use this Sing template. I observed that when building the project on my Windows developer laptop it builds fine but on our Linux server I was receiving the following error.

Error in bail mode: [at-loader] custom-typings.d.ts:71:6
Duplicate identifier 'FactoryEs6PromiseLoader'.

Per a stackoverflow forum I'm gathering that the es6-promise and core-js both cover the same promise definition; hence the error above. If I remove the following code from custom-typings.d.ts then it begin building fine. Has anyone else encountered this? What is the purpose of this code given core-js has the same type definition?

type FactoryEs6PromiseLoader = () => Es6PromiseLoader;
type FactoryPromise = () => Promise<any>;

type AsyncRoutes = {
[component: string]: Es6PromiseLoader |
Function |
FactoryEs6PromiseLoader |
FactoryPromise
};

type IdleCallbacks = Es6PromiseLoader |
Function |
FactoryEs6PromiseLoader |
FactoryPromise ;
Hello Boltondr,

We have never faced this issue (Linux, Win, OS X),

Cheers!
kparsee PURCHASED
Hello, I'm using your Angular 4 Seed project and I'm seeing issues with the datetime component's styling not working.

Here's my code:

Module:

import { NgModule } from '@angular/core';
import { CommonModule } from '@angular/common';
import { FormsModule } from '@angular/forms';
import { RouterModule } from '@angular/router';
import { CreatePackage } from './create-package.component';
import { CreatePackageNav } from './create-package-nav.component';
import { RequestPackageInfo } from './request-package-info/request-package-info.component';
import { InteragencyAgreement } from './interagency-agreement/interagency-agreement.component';
import { Documents } from './documents/documents.component';
import { Notes } from './notes/notes.component';
import { ReviewAndSubmit } from './review-and-submit/review-and-submit.component';
import 'ng2-datetime/src/vendor/bootstrap-datepicker/bootstrap-datepicker.min.js';
import 'ng2-datetime/src/vendor/bootstrap-timepicker/bootstrap-timepicker.min.js';
import { NKDatetimeModule } from 'ng2-datetime/ng2-datetime';
import { Autosize } from 'angular2-autosize';

export const routes = [
{ path: '', component: CreatePackage, children: [
{ path: '', redirectTo: 'requestPackageInfo', pathMatch: 'full' },
{ path: 'requestPackageInfo', component: RequestPackageInfo },
{ path: 'interagencyAgreement', component: InteragencyAgreement },
{ path: 'documents', component: Documents },
{ path: 'notes', component: Notes },
{ path: 'reviewAndSubmit', component: ReviewAndSubmit }

]}
];

@NgModule({
imports: [ CommonModule, FormsModule, NKDatetimeModule, RouterModule.forChild(routes) ],
declarations: [ RequestPackageInfo, InteragencyAgreement, Documents, Notes, ReviewAndSubmit, CreatePackage, CreatePackageNav, Autosize ],
exports: [CreatePackage]
})
export class CreatePackageLayoutModule {
static routes = routes;
}

html snippet:

<div class="col-md-3 ">
<datetime [(ngModel)]="desiredAwardDate" [timepicker]="false" name="desiredAwardDate" id="desiredAwardDate"></datetime>
</div>

component:

import { Component } from '@angular/core';

@Component({
selector: 'request-package-info',
templateUrl: './request-package-info.template.html',
styleUrls: [ './request-package-info.style.scss' ],
})
export class RequestPackageInfo {
desiredAwardDate: Date = new Date(2016, 5, 10);
}

.scss file:

@import "../../../../node_modules/ng2-datetime/src/vendor/bootstrap-datepicker/bootstrap-datepicker3.min";
@import "../../../../node_modules/ng2-datetime/src/vendor/bootstrap-timepicker/bootstrap-timepicker.min";
Hello Kparsee,

Try to check full version sources and make sure there are same styles and libs imported.

Have a nice weekend!
joseph PURCHASED
Hi guys,

I'm using Angular 4 Seed with Angular Cli to complie the project , but with something wrong.

=========================================================================
ERROR in ./src/app/scss/application.scss
Module build failed:
@import "../../../node_modules/glyphicons-halflings/scss/glyphicons-halflings";
^
File to import not found or unreadable: ../../../node_modules/glyphicons-halflings/scss/glyphicons-halflings.
Parent style sheet: stdin
in D:\BootstrapThemes\nt-portal-next\src\app\scss\application.scss (line 7, column 1)
@ ./src/app/app.component.ts 18:17-51
@ ./src/app/app.module.ts
@ ./src/main.ts
@ multi ./src/main.ts

Have any idea??

Cheers.
update node-sass version
Hello Joseph,

We don't support angular cli at the moment,
try to run 'npm start'.

Have a wonderful weekend!
Hi,

Is the Angular 4 project fully functional? Have all components been migrated to Angular 2/4?

Regards
Hello Valluri,

Yes, it is fully functional,
Some little subset of components may be missing (comparing to Ajax version) only.

Have a wonderful weekend!
Do you have an ETA on the React version? I'm about to start a new project.

Thank you!
Hello,

The react version of the Sing will be available in approx. 6-8 weeks.

Cheers!
Hi,

Can you suggest a way to implement autocomplete with data from Database?

Thanks.
Hello,

We have not implemented this feature yet, so we cannot assist you with the implementation at the moment.

Have a good week!
Hi there,

When do you think the React.js version will be ready?

Thank you very much.
Hello Alfanet,

We have not set the exact date just yet,
the React version will be available in approximately 2 months.

Thank you for your patience,
Cheers!
chase PURCHASED
Hi,
Using Angular 4 latest version. cannot make more than one dynamic table.
is it possible to use several 'Tables Dynamic' in several pages?
Thanks
Hello Chase,

Yes, it is possible. Our dynamic table component is more a template-thing, you can use it as the basis to make either a reusable component or various similar ones.

Cheers!
I'm trying to `npm install` the latest version 3.6.0 and I'm getting these errors:

Sing@3.6.0 /Users/carlos.hung/work/projects/integration/row-to-ng4/sing-wrapbootstrap-3.6.0/angular4-seed
├── @angular/animations@4.1.3
├── UNMET PEER DEPENDENCY @angular/common@4.1.3
├── UNMET PEER DEPENDENCY @angular/compiler@4.1.3
├─┬ @angular/compiler-cli@4.1.3 invalid
│ └── @angular/tsc-wrapped@4.1.3
├── UNMET PEER DEPENDENCY @angular/core@4.1.3
├── UNMET PEER DEPENDENCY @angular/forms@4.1.3
├── @angular/http@4.1.3
├── @angular/platform-browser@4.1.3
├── @angular/platform-browser-dynamic@4.1.3
├─┬ @angular/platform-server@4.1.3
│ └─┬ parse5@3.0.2
│ └── @types/node@6.0.78
├── @angular/router@4.1.3
├── UNMET PEER DEPENDENCY webpack@2.2.0-rc.2
└── UNMET PEER DEPENDENCY zone.js@0.7.4

npm WARN @angular/core@4.1.3 requires a peer of zone.js@^0.8.4 but none was installed.
npm WARN codelyzer@1.0.0-beta.4 requires a peer of @angular/compiler@~2.2.0 but none was installed.
npm WARN codelyzer@1.0.0-beta.4 requires a peer of @angular/core@~2.2.0 but none was installed.
npm WARN ng2-bootstrap@1.1.16-10 requires a peer of @angular/common@^2.4.0 but none was installed.
npm WARN ng2-bootstrap@1.1.16-10 requires a peer of @angular/compiler@^2.4.0 but none was installed.
npm WARN ng2-bootstrap@1.1.16-10 requires a peer of @angular/core@^2.4.0 but none was installed.
npm WARN ng2-bootstrap@1.1.16-10 requires a peer of @angular/forms@^2.4.0 but none was installed.
npm WARN sass-loader@4.1.0 requires a peer of webpack@^1.12.6 || ^2.1.0-beta but none was installed.
npm WARN string-replace-loader@1.0.5 requires a peer of webpack@1 || 2 || ^2.0.0-beta || ^2.1.0-beta but none was installed.
npm WARN webpack-dev-middleware@1.6.1 requires a peer of webpack@1 || ^2.1.0-beta but none was installed.
npm WARN Sing@3.6.0 No repository field.
npm WARN Sing@3.6.0 No license field.

I'd greatly appreciate your input.

Best,
Carlos
I did not have any issue running `npm install` with Sing@3.3.0.
I'm using npm v3.10.3 & node v6.4.0.

Thanks,
Carlos
Hello Carlos,

Please, update your node and npm - they are a bit outdated.

Cheers!
How can I change the loading-overlay style?
Hello Inceptio,
I apologize for the delay in getting back to you,
Could you contact us on support@flatlogic.com and explain what you are trying to achieve so we can help you?
Thank you for your patience!

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
3463Purchases

Licenses: Details »

Single application $24
Version:3.8.0
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: angular, angular4, bootstrap4, bower, html5, react, retina, sass, seed, web app
Item#:WB0J6BJ85
Released:2 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
okendoken

okendoken

Signed up 4 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: