885 comments

Missing multiselect in template, how is structure
Hello Inceptio,

Please, check out the form elements page.
Have a wonderful week!
Goodnight. How can I start the sidebar in static mode without pressing the button, so that when the page is loaded it is already open and static. Thanks for the help....
Hello Pwavilal,
If you are using angular 2 version, you should change app.config.ts file. You have to change ''nav-static" field to false in the config object.
For any other version of the template, please, do the same (have a look at the config's "nav-static' field).
Thanks So Much!!!!!
Hi okendoken, Chart libraries flot,d3, rickshaw are compatible with Angular 2 or 4?
Hi 10macit,

Apologies for the delay in coming back to you and thank you for your patience!

As for your question, they are compatible with both Angular 2 and 4.

Have a wonderful week!
As per documentation, I have completed installation of npm , bower and gult in Angular 4 folder. When i try to start the application with command "gulp serve "- it gives me an error "No gulp file found". I have installed gulp globally with -g option. Please help.
Hi Madhushri,
Thank you for purchasing!

It looks like you've checked the wrong section of the documentation :)
Could you check the section that mentions angular 2+ (2 or 4)? Please, notice that you don't need gulp there, we're using webpack for angular 4 version.

Please, let us know if it helps,
Cheers!
Hi guys,

Do you have any plan to migrate from the old hash routing to the new base href routing model Angular 4 is using? This is to make URLs simpler.
Hello, Vbenavidesa!

Yes, we are going to add it in one of the future releases.

Thank you for your question,
Cheers!
Hi I'm planning to buy this template to make a Single Page Application ERP system, I'm just wondering if this is available in Angular (2/4) version and by that I don't mean "AngularJS".

Also, are the components coded using Typescript ?

Lastly, what does a "seed project" means ?

Good Day Thanks :)
Hello, MetanoiaRichi!

Yes, there is the Angular 4 full version of the template.
Yes, the Sing is coded using Typescript.
The seed version is a light weighted version which includes the basic elements only.

Please, let us know if you have any other questions,
and feel free to contact us at support@flatlogic.com directly :)
Hi .. First time working on a Angular theme. The app starts default at Dashboard. How do I start default on a Splash page or Log In page ?
Hello, Digitaliq19!

Please, take a closer look at layout.routes.ts file.

Cheers!
Hello - I just purchased this template and am have an issue running the demo app. Getting the following error:

Node Sass could not find a binding for your current environment: OS X 64-Bit with Node.js 7.x

Can you recommend how to rectify?
Thanks!
Hello!
Could you try to delete the node-saas folder in node_modules and running npm install after that?

Please, let us know if it helps,
Cheers!
Have you integrated this theme (probably the basic Bootstrap 3 or 4 version) with Drupal before? Looking to see how much work would be required to use this as a Bootstrap subtheme.
Hello Cole,
We apologize for the delay in coming back to you,
No, we haven't integrated any of the Sing versions with Drupal yet.

Cheers!
Hi! How can i increase menu size on colapsed mode? My project's name is bigger than "sing".

Tks!
By size i mean width.
Hello Ricardocruz,

Please, check the variables.scss 'layout' section.

Thank you for your patience,
Have a wonderful week!
hi, can we use angular4 without the webpapk?
Hello Talis30,

Yes, you can,
(though our development team would not recommend you to do so).

Feel free to contact us via email directly (support@flatlogic.com),
Have a nice week!
Hello!
I'm using Sing for the first time, just trying to understand how to start the application.
Every time I try to run 'npm start' or 'npm run server', an error pops up. Command prompt (I'm on Windows) says that this fails on my system: "npm run webpack-dev-server -- --config config/webpack.dev.js --open --progress --profile --watch --content-base src/

I'm running node 7.7.2 and npm 4.1.2. Thanks!
Hello Menlotech,

Thank you for the provided details,
we have not faced such an issue before, apologies we can not advise on how to get this fixed at the moment,
Have a wonderful week!
The angular 4 seed project is a little misleading. Most thing should be components but they aren't. Its all custom html. And most of the css is in the non-seed package. Its a nightmare trying to figure out and make the forms look like they do on the demo page. I have no idea where all of this is. and scss has a million imports that aren't available. I'm confused at how to proceed. I feel like i can't even build an app with this.
Hello Micahosborne,

In the case you are looking to build an app using full version's components, a better workaround is to use the full version and clean it from the components you don't need. Could you give it a try?

Thank you for your feedback, we really appreciate it.
Have a wonderful week!
Hi,

Does your template has documentation?
Is it ease to customize the colors of the theme?

thanks
Alberto
Hello Alberto,

Yes, you can find the documentation we provide at the moment in the package, please, take a look at the documentation folder -> index.html file.
As for your second question, yes, it is possible to change the colors for elements. Please, refer to the variables.scss where you can find most of the colors declarations

Have a wonderful week!
Hi,
There is a missing style in the chat-sidebar version for angular 4. At bootstrap version, the scroll works well when you add some messages, but in the angular, there is no scroll for added messages. It is possible to see this at preview versions of bootstrap(working fine) and angular 4(not working).
Hello Bernardogontijo,
Thank you for letting us know,
We'll get this fixed in one of the future releases.

We appreciate your feedback,
Cheers!
I am trying to the React Dashboard Seed
I am getting this error when I do yarn start and open localhost:3000
Unexpected token < Uncaught SyntaxError: vendor.js:1
Unexpected token < Uncaught SyntaxError: client.js:1
Hello GopalPanigrahy,

Have you run 'yarn install'?
Hello,
How can I optimize the application on the server? It works very slow right now.
I'm using the Angular 4 version
Nor can I compile the application using the "npm run build: aot" command.

I got:

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! Sing@3.7.0 webpack: `node --max_old_space_size=4096 node_modules/webpack/bin/webpack.js "--config" "config/webpack.prod.js" "--progress" "--profile" "--bail"`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the Sing@3.7.0 webpack script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Dgtxd\AppData\Roaming\npm-cache\_logs\2017-07-30T05_19_00_986Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! Sing@3.7.0 build:aot:prod: `npm run clean:dist && npm run clean:aot && cross-env BUILD_AOT=1 npm run webpack -- --config config/webpack.prod.js --progress --profile --bail`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the Sing@3.7.0 build:aot:prod script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Dgtxd\AppData\Roaming\npm-cache\_logs\2017-07-30T05_19_01_055Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! Sing@3.7.0 build:aot: `npm run build:aot:prod`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the Sing@3.7.0 build:aot script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Dgtxd\AppData\Roaming\npm-cache\_logs\2017-07-30T05_19_01_113Z-debug.log
Hello Dartiles,
Unfortunately, we cannot help you with it as we do not support Aot at the moment.

We apologize for the delay in coming back to you,
Thank you for your patience!
joshert PURCHASED
It would be nice if the react version didn't contain all the server-side stuff as well, as it's painful to separate express.
Hello Joshert,

Thank you for the feedback, we appreciate you took a time to share it.
We are passing your words to the team.

Have a wonderful week,
Cheers!
Hello my client bought this theme and wanted me to work using this theme. but couple of things are missing or may be i coudn't figure it out

Is angular-cli not included in the theme for angular 4 release ? How do i integrate the theme with angular cli ?
Hello Ritish,

Please, notice that we do not support angular-cli at the moment,
Our apologies for this inconvenience.

Thank you for your patience and understanding,
Cheers!
Hello,
When I run "npm install", I get this error
npm ERR! Error while executing:
npm ERR! C:\Program Files\Git\cmd\git.EXE ls-remote -h -t git://github.com/jquery/jquery-ui.git
npm ERR!
npm ERR! fatal: unable to connect to github.com:
npm ERR! github.com[0: 192.30.253.113]: errno=No error
npm ERR! github.com[1: 192.30.253.112]: errno=No error
npm ERR!
npm ERR!
npm ERR! exited with error code: 128

How can I remove this?
And about angular-cli, do you have a date for the release?
The error is because I'm in proxy :)
So, could you only tell me when is the release for angular-cli?
Dear lrandriamiaramanana,
Thank you for reaching out to us!

Angular cli version will be available this autumn,
we are focusing on react version at the moment :)

Cheers!

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
3462Purchases

Licenses: Details »

Single application $24
Version:3.8.0
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: angular, angular4, bootstrap4, bower, html5, react, retina, sass, seed, web app
Item#:WB0J6BJ85
Released:2 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
okendoken

okendoken

Signed up 4 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: