885 comments

Hi, I want to buy the Angular2 versión, but how can I choose the correct version when I am paying?
When you purchase, you receive a package with all versions (ajax, angularjs, angular 2, etc.) and you can also download all updates I think.
bedardcorp,

yes. That's absolutely true.
Hi, first of all, thanks for this theme. It's totally awesome. We are facing a problem with components like tooltips, when we first navigate to the components page, they don't work. If we refresh the page, they start working. Will you fix that bug?

Thanks!
alvarormoya, hi

thank you for ypur report, we will fix it as soon as possible

thanks
dmastag PURCHASED
Hi,
I keep getting this error on teh Dynamic Tables on the 3.1.0 version of Angular2. How can I fix this?
main.bundle.js:37539 EXCEPTION: Error in ./TablesDynamic class TablesDynamic - inline template:28:87

Thanks
dmastag PURCHASED
Solved it, just had to install lodash
npm install --save lodash
I just bought this template and the zip archive isn't in valid format I cannot open it. I'm waiting for support at the moment.
mob008 PURCHASED
i had the exact same issue and had to use 7 zip which it seems can open it
Hi, I'm encountering two problems with your rc1 release.

I tried both your angular2 and angular2 seed version and to make sure that it isn't my os I've removed and reinstalled my node.js + npm + global packages.

Used the out of the box settings = without any chances

1. When I use the server the Uri isn't build in the right way:
http://localhost:3000/%3C%=%20webpackConfig.metadata.baseUrl%20%%3E#/app/dashboard
This occures in both test as production.

2. When I use the build:prod command, the dist folder is created. Only I get a couple of errors from plugins that are used.

See below;
ERROR in ./~/ng2-datetime/ng2-datetime.ts
[1, 49]: file should end with a newline

ERROR in ./~/ng2-datetime/ng2-datetime.ts
Module build failed: Error: Compilation failed due to tslint errors.
at report (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:70:11)
at Object.lint (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:58:3)
at Object.module.exports (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:139:8)
@ ./src/app/forms-elements/forms-elements.ts 6:21-57

ERROR in ./~/angular2-autosize/src/autosize.directive.ts
[12, 42]: missing whitespace
[14, 19]: missing whitespace
[17, 17]: missing whitespace
[20, 89]: " should be '
[8, 24]: missing whitespace

ERROR in ./~/angular2-autosize/src/autosize.directive.ts
Module build failed: Error: Compilation failed due to tslint errors.
at report (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:70:11)
at Object.lint (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:58:3)
at Object.module.exports (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:139:8)
@ ./~/angular2-autosize/angular2-autosize.ts 5:27-62 6:9-44

ERROR in ./~/ng2-slimscroll/src/directives/slimscroll.directive.ts
[95, 3]: Declaration of private instance member variable not allowed to appear after declaration of private instance member function
[129, 3]: Declaration of private instance member variable not allowed to appear after declaration of private instance member function

ERROR in ./~/ng2-slimscroll/src/directives/slimscroll.directive.ts
Module build failed: Error: Compilation failed due to tslint errors.
at report (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:70:11)
at Object.lint (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:58:3)
at Object.module.exports (C:\Industrylinq\test2\node_modules\tslint-loader\index.js:139:8)
@ ./~/ng2-slimscroll/ng2-slimscroll.ts 5:29-77 6:9-57
Child html-webpack-plugin for "index.html":
+ 1 hidden modules
Hi, just checking in to see when we can expect for the bugs in webpack.
Als was wondering if you guys are planning an upgrade to RC 3.

Thnx,

Roel
What's the building tool? gulp or grunt?
Hi odelya_light!

It's webpack.

thanks
a4756830 PURCHASED
Can you Help me? How to install Agnualr Speed To asp.net mvc

My Email:
a4756830@gmail.com
Hi

Unfortunately we haven't Sing with mvc version, so we can't clearly say how to install it
Hi, I'm still encountering two problems with your rc1 release.

I tried both your angular2 and angular2 seed version and to make sure that it isn't my os I've removed and reinstalled my node.js + npm + global packages.

Used the out of the box settings = without any chances

1. When I use the server the Uri isn't build in the right way:
http://localhost:3000/%3C%=%20webpackConfig.metadata.baseUrl%20%%3E#/app/dashboard
This occures in both test as production.

2. When I use the build:prod command, the dist folder is created. Only I get a couple of errors from plugins that are used.
travtion PURCHASED
Hi!!, I need to add new libreries as VisualSearch.js in the template Sing App - Web & Angular 2.0.
Can you give me an example or steps to do this?
Hi, travtion.

Please, write your question to the contact@flatlogic.com

We will answer you.
thanks
TiagoReis PURCHASED
I'm sorry, but this is not working. angular2-seed installs OK (btw - it doesn't have animations while switching between views!), but angular2 version doesn't install!!

Please reply with a solution / workaround. Log:

gyp ERR! build error
gyp ERR! stack Error: `msbuild` failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Users\Tiago\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\build.js:276:23)
gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:204:12)
gyp ERR! System Windows_NT 10.0.10586
gyp ERR! command "C:\\Program Files (x86)\\nodejs\\node.exe" "C:\\Users\\Tiago\\AppData\\Roaming\\npm\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\SingTemplate\angular2\node_modules\jsdom\node_modules\contextify
gyp ERR! node -v v6.3.0
gyp ERR! node-gyp -v v3.3.1
gyp ERR! not ok
npm WARN optional Skipping failed optional dependency /webpack/watchpack/chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.12
npm WARN enoent ENOENT: no such file or directory, open 'C:\SingTemplate\angular2\node_modules\contextify\package.json'
npm WARN Sing@3.1.0 No repository field.
npm WARN Sing@3.1.0 No license field.
npm ERR! Windows_NT 10.0.10586
npm ERR! argv "C:\\Program Files (x86)\\nodejs\\node.exe" "C:\\Users\\Tiago\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! node v6.3.0
npm ERR! npm v3.10.3
npm ERR! code ELIFECYCLE

npm ERR! contextify@0.1.15 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the contextify@0.1.15 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs contextify
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls contextify
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\SingTemplate\angular2\npm-debug.log
davczek PURCHASED
I have the same.
Hi TiagoReis, hi davczek!

As per Sing documentation you have to install Visual C++ Build Tools in order to run on Windows 10 (don't forget to install windows 10 extenstions!). For more detailed documentation please follow this guide https://github.com/nodejs/node-gyp/issues/629

thanks
asware PURCHASED
I am having this same error for the angular2 version, the angular2seed is okay, see the message below.
The link in your documentation goes to an error page on Microsoft website (For Windows 10 install the Visual C++ Build Tools 2015 Technical Preview, not Visual C++ Build Tools 2015.)
I have VS2015 installed on my system
You need to provide a step by step guide on how this issue can be resolved

------------------------------------------------------------------------------------------------------------------------------------------
Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\Users\anu>cd C:\My Stuff\StuffDev\SpringWare\sing-wrapbootstrap-3.1.0\angular2Dev

C:\My Stuff\StuffDev\SpringWare\sing-wrapbootstrap-3.1.0\angular2Dev>npm install

> contextify@0.1.15 install C:\My Stuff\StuffDev\SpringWare\sing-wrapbootstrap-3.1.0\angular2Dev\node_modules\contextify
> node-gyp rebuild

C:\My Stuff\StuffDev\SpringWare\sing-wrapbootstrap-3.1.0\angular2Dev\node_modules\contextify>if not defined npm_config_node_gyp (node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "" rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable.
gyp ERR! stack at failNoPython (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:401:14)
gyp ERR! stack at C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:356:11
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:123:15)
gyp ERR! System Windows_NT 10.0.10586
gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
gyp ERR! cwd C:\My Stuff\StuffDev\SpringWare\sing-wrapbootstrap-3.1.0\angular2Dev\node_modules\contextify
gyp ERR! node -v v6.3.0
gyp ERR! node-gyp -v v3.3.1
gyp ERR! not ok
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.14
npm WARN angular2@2.0.0-beta.17 requires a peer of zone.js@^0.6.12 but none was installed.
npm WARN angular2-datatable@0.4.2 requires a peer of lodash@^4.0.0 but none was installed.
npm WARN Sing@3.1.0 No repository field.
npm WARN Sing@3.1.0 No license field.
npm ERR! Windows_NT 10.0.10586
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! node v6.3.0
npm ERR! npm v3.10.3
npm ERR! code ELIFECYCLE

npm ERR! contextify@0.1.15 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the contextify@0.1.15 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs contextify
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls contextify
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\My Stuff\StuffDev\SpringWare\sing-wrapbootstrap-3.1.0\angular2Dev\npm-debug.log

C:\My Stuff\StuffDev\SpringWare\sing-wrapbootstrap-3.1.0\angular2Dev>
Hello Philip,
I've download Sing dashboard and I want to know how could I implement it in current Angular-CLI application.
Second that
Hi ahmedemadmohmaed!

Thanks for interest in our template!

I don't see a "PURCHASED" badge next to your nickname. Have you purchased our app?

Thanks
Good morning,
Buy the template I'm working on angular2 but I need to run on Linux (Ubuntu 14.04) I could collaborate shows me errors when installing the install npm are dependencies appreciate the attention.

Thank you
blue PURCHASED
You may want to post a couple of lines here containing some of the errors (not warnings); maybe another user or one of the devs will chime in if you post a few details. Not knowing your npm background, I'll mention that some dependency *warnings* are to be expected. Also, at least one person here reports having to install lodash separately after running npm install in order to get the demo working:

npm install --save lodash

Then (warnings notwithstanding), try running using

npm run server:dev

and see if the demo comes up on

http://localhost:3000
Someone can help me please.
Hi dartecno!

What's your problem?
blue PURCHASED
Any sense as to when a demo and starter using Angular2 RC4 will be available? Specifically, it would be great to see a demo update that:

- uses the new router (@angular/router) instead of router-deprecated
- includes a rich form widget example similar to the "Form Elements" example in the current Sing demo, but using the new forms API (@angular/forms) as the old one has been deprecated. See https://angular.io/docs/ts/latest/guide/forms.html

I just reviewed the backlog of angular/angular issues for RC5 and RELEASE on GitHub, and it seems to me there is a good chance that it would be safe to code to the above APIs without major breaking changes coming down the pike.
Hi Blue!

Thanks for purchase!

I think we can wait for the final release - it's already 20% ready and is growing every day.

However, we'll take a look at @angular/router (seems like the most valuable change) and check if it's easy to switch to. If so, then we'll do RC4 release, otherwise we'll wait for the final release.

I hope it makes sense for you!

Best
JamesB PURCHASED
This is a fantastic template. That new component router is the ONLY thing holding us back from purchasing this now. I think it's safe for you to update the template to the new router since Google Devs said "it's the way forward". Buying this with the old router would mess up our existing code, so we would really appreciate it if you COULD upgrade that router! Thanks so much. (great job!)
esneivro PURCHASED
Absolutely agree!. I've stopped my development because probably there will be major changes in the structure. It would be nice if you include some kind of security logic based on the new router. I mean some components secured and not accesible if you're not logged in. Seems to be that there are major changes in forms too, so probably has no sense to continue working with actual version...

Anyway of course I'd recommend that project!!!

Thanks.
dnix92 PURCHASED
Hi,

this is really great work! I have one question though...

is it possible to convert this to use the Angular-CLI?

Thanks.
Hi,

thank you for your reply,

Sorry, but we don't provide steps of converting to Angular-CLI
Hi,

I have purchased this theme and want to run angular 2 app from the downloaded project in visual code.

I am getting below error message when i am executing below instruction.

Run npm install to install node dependencies defined in package.json and to install typings defined in typings.json

git://github.com/jquery/jquery-ui.git#1.11.4 resetting remote C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-github-com-jquery-jquery-ui-git-1-11-4-96604f67 because of error: { [Error: Command failed: git -c core.longpaths=true config --get remote.origin.url

Thank you for earliest reply.
mindworx PURCHASED
Hi,

I have purchased this theme and want to run angular 2 app from the downloaded project in visual code.

I am getting below error message when i am executing below instruction.

Run npm install to install node dependencies defined in package.json and to install typings defined in typings.json

ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror git://github.com/stevepapa/angular2-autosize.git
C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-github-com-stevepapa-angular2-autosize-git-5a030f92890d0531b73272b337b0d736940bd24e-dd242706: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror git://github.com/stevepapa/angular2-autosize.git
C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-github-com-stevepapa-angular2-autosize-git-5a030f92890d0531b73272b337b0d736940bd24e-dd242706: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror git://github.com/jquery/jquery-ui.git
C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-github-com-jquery-jquery-ui-git-1-11-4-96604f67: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror git://github.com/jquery/jquery-ui.git C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-github-com-jquery-jquery-ui-git-1-11-4-96604f67: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror https://github.com/HubSpot/messenger.git C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-https-github-com-HubSpot-messenger-git-v1-4-2-62a357d5: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror https://github.com/HubSpot/messenger.git C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-https-github-com-HubSpot-messenger-git-v1-4-2-62a357d5: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror git://github.com/HubSpot/pace.git C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-github-com-HubSpot-pace-git-v0-7-1-6a6dbbcd: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror git://github.com/HubSpot/pace.git C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-github-com-HubSpot-pace-git-v0-7-1-6a6dbbcd: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror https://github.com/jhuntoo/ng2-slimscroll.git C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-https-github-com-jhuntoo-ng2-slimscroll-git-5c84226a1beaec21456e08760cb2598344a919e8-16f267be: undefined
npm ERR! git clone --template=C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\_templates --mirror https://github.com/jhuntoo/ng2-slimscroll.git C:\Users\kasappa sutar\AppData\Roaming\npm-cache\_git-remotes\git-https-github-com-jhuntoo-ng2-slimscroll-git-5c84226a1beaec21456e08760cb2598344a919e8-16f267be: undefined

Thank you for earliest reply.
My very inexperienced comment - can you try if you are connected to internet. Try to access the git repositories on a browser to check if you are able to reach the repositories
Hi, I purchased the Sing Dashboard recently and I am following the instructions to install angular 2 version. At the bower install, I am getting an error saying "bower.json" not found, please advise.

PS: The link to attach my order to the profile has expired, I have requested a new link and I am not sure when will I get the new email to attach my order to the profile. This is my Order#: WB06R8542
Hi,

on angular 2 version we use only npm packager, we don't have bower
I am trying the Ajax version and came across this issue:
As per the documentation, you suggest to remove the "vendor" directory, but when I do a gulp I am getting an error

Documentation
his version includes built and compiled node_modules and vendor folders. In order to properly build Sing App dependencies you may want first to remove node_modules and vendor folders by running rm -r node_modules/, rm -r vendor/.'

Error
sass/application.scss
Error: File to import not found or unreadable: ../vendor/bootstrap/scss/bootstra
Hi, we suggest to remove folders if you have some problems with running of the project. But, after deleting you must reinstall libraries by running npm install and bower install

thanks

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
3461Purchases

Licenses: Details »

Single application $24
Version:3.8.0
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: angular, angular4, bootstrap4, bower, html5, react, retina, sass, seed, web app
Item#:WB0J6BJ85
Released:2 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
okendoken

okendoken

Signed up 4 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: