885 comments

I just purchased theme and tried to use it but it does not work. I have some many issues while npm install.

Firstly there is no Visual C++ Build Tools 2015 Technical Preview to install.
Secondly when I did npm install so many err coming .
I am with same problem. I don´t understand why whould install Visual C++ Build Tools 2015 Technical Preview to install project and not justexecute npm install?
To solve those error
You need to follow the steps to install node-gyp

Reference : https://github.com/nodejs/node-gyp
I have an issue scrolling down on iPhones. It works on android, but not iPhone..
I have this issue too, it's not working with angular2. I even downloaded it and ran it and checked it on browserstack, it just doesn't work on iPhones.
Hello, we are experiencing the same issue on an iPhone 6S+. Here is what we noticed to help you reproduce the issue:

* Scrolling on the side to reveal the menu and the chat seem to work fine.
* In the forms page scrolling works.
* The chat wondow does not scroll once filled with messages (the one with one to one messages, not the list of people to chat with). This point does not work on Android and Desktop either.

Thank you in advance for any help on this.
If it helps, my website works perfectly on Andriod.
The problem is with IOS only. Also, The scrolling seems to work if you are touching/dragging an input element. Which is weird.
We also have noticed what lalvarez85 says. Seems like you can scroll when you touch/drag an input element.
I have debugged safari on iphone, there is a javascript error around 'Intl'. You need to add the polyfill for intl (ios safari doesnt handle the intl pipe), as that is causing the error.

add below to head of index.html
<script src="https://cdn.polyfill.io/v2/polyfill.min.js?features=Intl.~locale.en"></script>
Hi to all,sorry for delay,we had vacation time.

We are sorry for this delay, and thank you for your help and fixing this bug, we will update Sing with it.
Adding the script didn't fix the error in browserstack.
Dear, when solved the problem?
Hi, sorry for delay,we had vacation time.

yoongkang0122 has answered your question higher.
Is it developer in TypeScript?
What is process for build development and production?
The Angular 2 version is in TypeScript.
Hello, I have recently purchase Sing APP Dashboard..
when i try to install angular 2 dashboard using "npm install".
I am getting error
-----------------------------------------------------------------------------------------

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.14
npm WARN angular2-google-maps@0.12.0 requires a peer of @angular/common@2.0.0-rc.2 but none was installed.
npm WARN angular2-google-maps@0.12.0 requires a peer of @angular/compiler@2.0.0-rc.2 but none was installed.
npm WARN angular2-google-maps@0.12.0 requires a peer of @angular/core@2.0.0-rc.2 but none was installed.
npm WARN angular2-google-maps@0.12.0 requires a peer of @angular/platform-browser@2.0.0-rc.2 but none was installed.
npm WARN angular2-google-maps@0.12.0 requires a peer of @angular/platform-browser-dynamic@2.0.0-rc.2 but none was installed.
npm WARN angular2-google-maps@0.12.0 requires a peer of reflect-metadata@^0.1.3 but none was installed.
npm WARN Sing@3.1.1 No repository field.
npm WARN Sing@3.1.1 No license field.
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! node v6.3.1
npm ERR! npm v3.10.3
npm ERR! code ELIFECYCLE

npm ERR! contextify@0.1.15 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the contextify@0.1.15 install script 'node-gyp rebuild'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs contextify
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls contextify
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\MyNode\angular2\npm-debug.log
--------------------------------------------------------------------------------------------------

I am using window 7 and node v6.3.1.
We are trying to install your angular2 template from last 2 days, getting many errors as mentioned in above topic. Please reply asap.
Same issue I am getting !! Any luck you solving it ?
Support Team,

Why you are replying to issues in your ang2 template. We need quick support, otherwise there is no use of purchasing template from you guys. This is not good support at all.

Thanks,
Naren
This is a complete lack of respect for the buyers. Not recommend anyone buy layout flatlogic. Horrible support.
To solve some of the error regarding node-gyp and contexity
You need to follow the steps in below reference to install node-gyp

Reference : https://github.com/nodejs/node-gyp
Hi to all, sorry for delay,we had vacation time.

Yes, yoongkang0122 is right, it solves the problem.

And thank you for your patience.
ramirex PURCHASED
I have problems trying to run the app,
when a type npm install, there are problmes with jquer-ui and others git scipts, so I erased from the package json, after that this is another error that cameup
7823 verbose unsafe-perm in lifecycle true
7824 info Sing@3.1.1 Failed to exec install script
7825 verbose stack Error: Sing@3.1.1 install: `napa`
7825 verbose stack Exit status 1
7825 verbose stack at EventEmitter.<anonymous> (C:\Program Files\nodejs\node_modules\npm\lib\utils\lifecycle.js:217:16)
7825 verbose stack at emitTwo (events.js:87:13)
7825 verbose stack at EventEmitter.emit (events.js:172:7)
7825 verbose stack at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\lib\utils\spawn.js:24:14)
7825 verbose stack at emitTwo (events.js:87:13)
7825 verbose stack at ChildProcess.emit (events.js:172:7)
7825 verbose stack at maybeClose (internal/child_process.js:827:16)
7825 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)
7826 verbose pkgid Sing@3.1.1
7827 verbose cwd C:\Users\meghan\angular2\sign
7828 error Windows_NT 6.1.7601
7829 error argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
7830 error node v4.4.7
7831 error npm v2.15.8
7832 error code ELIFECYCLE
7833 error Sing@3.1.1 install: `napa`
7833 error Exit status 1
7834 error Failed at the Sing@3.1.1 install script 'napa'.
7834 error This is most likely a problem with the Sing package,
7834 error not with npm itself.
7834 error Tell the author that this fails on your system:
7834 error napa
7834 error You can get information on how to open an issue for this project with:
7834 error npm bugs Sing
7834 error Or if that isn't available, you can get their info via:
7834 error
7834 error npm owner ls Sing
7834 error There is likely additional logging output above.
7835 verbose exit [ 1, true ]
Hi, sorry for delay,we had vacation time.

If it is actual answer, please contact us by email
Please update Angular 2 version to use RC 5 .

There is a change with RC5 using ngModule to bootstrap angular 2 apps.

I have tried making these changes with SING angular 2 version, but to no success. I am not sure what is going wrong, perhaps there is some specific change I need to make to WebPack?

Regardless, if you could please update that would really great.

Cheers

Nigel Dewar
Is it possible to integrate the Sing Template in the new angular-cli RC5 webpack version?
Hi to all, sorry for delay,we had vacation time.

Now RC7 version has come, so our release is delayed for another week.

and we will not use angular-cli, cause now it has not stable version and has a lot of issues. we will wait for more clear status of angular and angular-cli to update
d3x73r PURCHASED
It is possible to add the same left sidebar on the right???
Hi, sorry for delay,we had vacation time.

We are not using the same behavior for the right sidebar, if you want, you can do it yourself.
Following the directions, I Installed the AngularJS(1) no problem, but can't get the AngularJS2 version installed. Using npm, it's just a sea of errors. Would really appreciate some basic support here, like being able to get this installed properly.
Hi, sorry for delay,we had vacation time.

If it is actual question, contact us by email
yeah cool idea, wish it was updated for RC5 and worked on iOS. Noticed like everyone else that it does not scrolling does not work on iOS. Oh well.
Hi, sorry for delay,we had vacation time.

We are working on updating to RC7 now. for Ios, you can fix it yourself, while we haven't updated Sing yet:
add below to head of index.html
<script src="https://cdn.polyfill.io/v2/polyfill.min.js?features=Intl.~locale.en"></script>
Hi Philip,

After reading multiple request on the Sing App discussion, I wanted to ask a couple of questions/requests.

Can you update the SIng App to rc5 for Angular 2. Currently the template is out of sync with the latest router module, forms module and the NgModule is new in RC 5.

My second request is if you can update the webpack part of the development environment.
Takes a long time to load the development server and webpack has released a newer version of there software with better results,

Final remark would be the suggestion to use the angular-cli webpack version as the development environment.

Currently using it and the benefits are significant. Webpack test server loads fast and the build functionality compilates also in record time.

Love your template and hope that you can follow up on my feedback,
Cheers,

Roel
+1 With the requests made by industrylinq. It would be really nice to have these since it seems that they will be in the final release when it comes out.

:)
Hi industrylinq!

Thanks for purchase!

As of RC5 and webpack updates they are already in progress. The update is going to be available in a week.

As of switching to angular-cli - we made a small investigation of it and decided it's: a) to inmature to migrate to, b) going to cost too much time to switch to cli and c) it will be a completely different build approach. Hence currently we don't have a plan to update to angular-cli.

Let me know if there anything else I can help you with!

Cheers
Raph246 PURCHASED
Also getting a lot of errors even after having properly installed node-gyp anf followed the recommanded steps (on windows). Seriously guys you need to make a real effort on customer support here. Your app looks great but if your customer can't manage to run it there is no point in purchasing it. Please help us fix this problem so we can all fully enjoy your work.
If you are on a windows machine. Make sure that you open powershell or your terminal with administrator rights before you install any npm packages.

Also when you want to compile or run your test server.
when i use the starter angular 2 template the typescript source map always are blank/empty i cannot do debug can you help me?
Hi, sorry for delay,we had vacation time.

We are updating now to RC7 version and will fix it.

thank you
I know you have probably been asked this many times, however I cannot find a definitive answer, I have contacted wrapbootstrap multiple times with no reply.

Which license would be suitable if using this template as a base for a web app hosted on a single domain with one database that users can sign up to use its services at a small monthly cost? (There will be a free plan too)

The theme would not be resold, the users would only be able to use the services, social media scheduling features for example.

Any help would be much appreciated as I have seen conflicting answers on this site and not received a reply from support here.
Hi,

You can use Single license
Hi,

I found a bug with the collapsing sidebar. I was wondering if you might be able to help me fix it. I'm using the html/css/jquery version, but I noticed it in the demo as well.

When I'm on a secondary page, like UI Elements > Buttons with the sidebar open, and then collapse the sidebar, the sub-nav remains expanded.

Thanks,
Charraye
Hi,

please, contact us by email and tell please more info about it, cause i cant reproduce this issue.
jsbotio PURCHASED
When you guys release ECMAScript 6 support for angular 2.0 version ?
Hi jsbotio!

What do you mean by ES6 support. It's actually done in typescript.
Greetings from Colombia.

I just made the purchase.

But not quite understand everything that has developed, I thought it was simple Angular 2 RC 4, but I see that there are many things, someone can give me a brief explanation of this template, I do not mean Angular 2, I mean everything having WebPacks etc ..

Thank you
Hi,

please, read the documentation, there are all info.
danya9365 PURCHASED
angular2-seed work well

but angluar2 npm install with failed many many times.
Regards danya9365,

That is, could you start algular2-seeds?

Okay, because it's what I need to start ... and hope that developers publish an updated version without errors ..

Thank you.
danya9365 PURCHASED
Today I try with many many time.
Finally Angular2 with full theme work now
Thanks.

I think the problem happened depending on plugin dependency host and my internet connection.
Greetings, you could tell me how I can have a seed project, the template is very beautiful but very complex to start development, ay it is not possible to identify the basic components.
ronaldrenteria

Thanks for purchase!

In a root folder of your purchase there are subfolders named angular2-seed and angular-seed. Please use one which better suits your needs.

Let me know if you'll have any more issues.
So far working well. Can you pl help me understanding how to add a custom .js using your webpack packaging as that part is not documented well. I need to add and being able to use it.
node_modules/jq-simple-connect/source/jqSimpleConnect.js
Hi sauverma16!

Thanks for purchase!

It seems that jqSimpleConnect is a plain js lib and thus requires typings definitions to be added to the project.

I wasn't able to find definitions in official typings registry hence you probably need to contact package author to add them here https://github.com/typings/registry.

Let me know if you have any other questions!
I'm having trouble running npm install in angular2 seed, someone can give me a hand with this, please.

Thank you.
what error are you seeing? i just did this a few days back and may be able to help
Greetings, I want to say that I abandoned this template, because it is very complex, does not have a seed project and thus is very difficult to start with developments, if you could share a seed project, would be helpful.

Thank you.
Hi ronaldrenteria!

Please let me know what do you see in a console? Which errors?

Thanks

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$24
3462Purchases

Licenses: Details »

Single application $24
Version:3.8.0
Type:
  • HTML Template
Bootstrap: Compatible with 4.x
Layouts:
  • Responsive
Browsers:
  • IE 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:No
Uses Sass:Yes
Categories:
Tags: angular, angular4, bootstrap4, bower, html5, react, retina, sass, seed, web app
Item#:WB0J6BJ85
Released:2 years ago
Updated:1 month ago
Sold exclusively on WrapBootstrap
okendoken

okendoken

Signed up 4 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: