3932 comments

When can we expect the latest SmartAdmin Responsive Update ??? Is it possible this month ???? Have started a project so just need an approx date so that I could figure out whether to continue with the current version that I have or should wait... otherwise would have to build all over again for the latest update. I am using Angular 4
Hello,

Whether you wish to wait for BS4, 5, or 6, that is something we cannot advise you on. Your users will not know the difference so much. The application will look and feel, almost the same. You can refer to bootstrap migration docs to think about if its worth the wait. https://v4-alpha.getbootstrap.com/migration/

Thanks,
Support
LMPSW PURCHASED
What is the best way to add the "comma" as a confirmKey for the tagsinput class? I know that bootstrap has this function:
$('input').tagsinput({
confirmKeys: [13, 44]
});

But that function does not appear be accessible with just the class selector ('.tagsinput').

Thank you.
Hello,

Please reach us through the proper channel for support. Instructions are found here: https://wrapbootstrap.com/user/MyOrange

Thanks,
Support
Eduards PURCHASED
Hello,

As I understood, I have to buy separate license for CK Editor. Other plugins are free of charge?
I mean I am one developer and I use Smartadmin in one online application, I use single application license while I don't charge money for using my application and I buy extended license when I start to charge for using my application. Is that ok if I don't use CK Editor or there is something else which requires additional licensing?
hi,

Yes that is correct. You can exclude CK editor from your project.

Regards
Support
Eduards PURCHASED
About CK I understand. Main concern is if CK is the only thing I have to exclude. So everything else is free of charge/included in Smartadmin license?
Yes that is correct. They are all MIT license.
Eduards PURCHASED
Thank you. By the way, can you recommend any free alternative to CK editor? WYSIWYG is very few used in my app, so anything which has text formatting is ok.
You can try summernote or markdown, both are free to use, lightweight and works well with any webapp.

Examples
http://192.241.236.31/themes/preview/smartadmin/1.8.x/ajax/index.html#ajax/other-editors.html
Eduards PURCHASED
Thank you
Hi, I think you have a small bug in demo (Ajax version): http://192.241.236.31/themes/preview/smartadmin/1.8.x/ajax/index.html
Hi,

That's not a bug, you are using the wrong URL. Here is the correct one:

http://192.241.236.31/themes/preview/smartadmin/1.8.x/ajax/index.html#ajax/dashboard.html

Thanks,
Support
Hello! We noticed that DataTable responsivity isn't working on ReactJS version. Is it a bug, or there is some limitation using ReactJS version?

Kind Regards.
Hi,

That is the limitation of Datatables, it is not responsive by default. You have to use a special plugin. Please check the HTML version for the sample code, we have made the datatables responsive in it.

Thanks,
Support
yaney PURCHASED
Hi,
I just ran the ASP.NET Core project (full project) "out of the box" and the UI does not load well, meaning pages, views are not rendering well. It feels like the style is not working. Nothing but the connection-string was modified. Am I missing something?
hi,

Its most likely your CSS paths. See your network log for error. Please contact us on support email if you are having issues.
bjy PURCHASED
I ask you about Jarvis-widget.
First of all, I am using the AngularWs 1.6 version.
On the html page, the widget buttons normally appear. However, once I visit the other html pages, the widget buttons are missing.
If you want to view the widget buttons, press refresh (F5) to resume normal playback.
Why does it work like this? I'm curious.
I want your help.
below my html source.

<div id="content" title="Hisotry">
<div class="row">
<big-breadcrumbs items="['History', 'Subtitle']" icon="home"
class="col-xs-12 col-sm-7 col-md-7 col-lg-4"></big-breadcrumbs>
</div>

{{test}}

<!-- widget grid -->
<section id="widget-grid" data-widget-grid>
<!-- row -->
<div class="row">
<!-- NEW WIDGET START -->
<article class="col-xs-12 col-sm-6 col-md-6 col-lg-6">
<!-- Widget ID (each widget will need unique ID)-->

<div data-jarvis-widget id="wid-id-0" data-widget-colorbutton="false"
data-widget-editbutton="false" data-widget-togglebutton="false"
data-widget-deletebutton="true" data-widget-color="greenLight"
>

<!-- widget options:
usage: <div data-jarvis-widget id="wid-id-0" data-widget-editbutton="false">
data-widget-colorbutton="false"
data-widget-editbutton="false"
data-widget-togglebutton="false"
data-widget-deletebutton="false"
data-widget-fullscreenbutton="false"
data-widget-custombutton="false"
data-widget-collapsed="true"
data-widget-sortable="false"
-->
<header >
<h2>
<strong>Full</strong> <i>Screen</i>
</h2>
</header>
<!-- widget div-->
<div>
<!-- widget content -->
<div class="widget-body">
<h2 class="alert alert-success">Make any widget full screen</h2>
<code>data-widget-fullscreenbutton</code>
<br> <br>
<p>Usefull when viewing images, gallery, tables with large
data and maps. There are much useful applications to this
method</p>
</div>
<!-- end widget content -->
</div>
<!-- end widget div -->
</div>
<!-- end widget -->
</article>
</div>
</section>

</div>
Hi,

Please use our support email instead. Details here: https://wrapbootstrap.com/user/MyOrange

Thanks,
Support
duansun PURCHASED
Hi,
I'm like SmartAdmin, it has rich components help me save a lot of time. May I know do you have plan develop version of Vue JS?
Hi,

Thank you for your support. It really means a lot! Yes we do have plans. We will start development after 2.0 release.

Thanks,
Support
Will SmartAdmin 2.0.0 update include:
> .NET Core 2.0 full website project
and
> .NET Core 2.0 seed project

If yes, then is there any way I can get early/beta access to seed project for .NET Core 2.0?
Hi,

Yes everything will be upgraded, including the version variations. The delay currently is due to BS4 is still in first stage of beta. And there are lots of changing within their code everyday, so to save time and not having to do any 'rework' we are patiently waiting for BS4 to be stable. Mean time we are playing with gulp, grunt, yarn, and various package managers and SCSS functions to make the theme extremely modular.

We also have plans to create a way to generate 'seed projects' - so you can literally turn off features you do not need and generate the CSS/HTML related to your development need. Making the project extremely lightweight.

I don't want to say too much at this stage, less talk more work on our end ;)

Also the price of SA will be largely increased in the future so its best to get your copy early so you have access to our updates for free through wrapbootstrap.

Thanks,
Support
Eduards PURCHASED
Hello MyOrange,

Just noticed such thing: you have menu with 20 1st level items, 20 2nd level items for first and some 2nd level items for another. Like this:

1
1.1
2.1
...
20.1
2
3
4
4.1
4.2
5
...
20

Now when you open item 1, so all 2nd level items appear, than you keep it opened, scroll down to item 4 (which is 1000px from the top) and open it. At this time you have scrolled down, for example, 800px. Than item 1 closes and item 4 on which you clicked goes up and it becomes 200px from the top. And that means item 4 disappears from screen because you have already scrolled down. (haven't tested it in different browsers, in FIrefox it is like this).

What I want to do is either make that when opening one submenu if needed menu gets scrolled to another position or it just doesn't close other submenus. Can you give me an advice, where should I do it?
Hi,

I actually have no idea what you are referring to. Please use our support protocol to reach us with your questions. https://wrapbootstrap.com/user/MyOrange

Thanks,
Support
Hello,
I liked your application but we are developing our software in laravel.

Do you have any larave package created for this?
Or can you help me if there is a way i can use this application to laravel.

Thank you,
Sudhir P.
Hello,After I run "npm start",show errors:
ERROR in AppModule is not an NgModule

ERROR in ./~/_jQuery@1.7.4@jQuery/lib/node-jquery.js
Module not found: Error: Can't resolve 'xmlhttprequest' in '/Users/wangxin/Sites/SmartAdminAngularJS_4.x/seed-project/node_modules/_jQuery@1.7.4@jQuery/lib'
@ ./~/_jQuery@1.7.4@jQuery/lib/node-jquery.js 8:28-53
@ ./~/_imports-loader@0.7.1@imports-loader?jQuery=jquery!./~/_jquery-color@1.0.0@jquery-color/jquery.color.js
@ ./src/lib.ts
@ ./src/main.ts
@ multi webpack-dev-server/client?http://localhost:4200 ./src/main.ts

ERROR in ./~/_jQuery@1.7.4@jQuery/lib/node-jquery.js
Module not found: Error: Can't resolve 'location' in '/Users/wangxin/Sites/SmartAdminAngularJS_4.x/seed-project/node_modules/_jQuery@1.7.4@jQuery/lib'
@ ./~/_jQuery@1.7.4@jQuery/lib/node-jquery.js 13:24-43
@ ./~/_imports-loader@0.7.1@imports-loader?jQuery=jquery!./~/_jquery-color@1.0.0@jquery-color/jquery.color.js
@ ./src/lib.ts
@ ./src/main.ts
@ multi webpack-dev-server/client?http://localhost:4200 ./src/main.ts

ERROR in ./~/_jQuery@1.7.4@jQuery/lib/node-jquery.js
Module not found: Error: Can't resolve 'navigator' in '/Users/wangxin/Sites/SmartAdminAngularJS_4.x/seed-project/node_modules/_jQuery@1.7.4@jQuery/lib'
@ ./~/_jQuery@1.7.4@jQuery/lib/node-jquery.js 17:25-45
@ ./~/_imports-loader@0.7.1@imports-loader?jQuery=jquery!./~/_jquery-color@1.0.0@jquery-color/jquery.color.js
@ ./src/lib.ts
@ ./src/main.ts
@ multi webpack-dev-server/client?http://localhost:4200 ./src/main.ts

ERROR in ./~/_jsdom@9.12.0@jsdom/lib/jsdom/living/xmlhttprequest.js
Module not found: Error: Can't resolve 'child_process' in '/Users/wangxin/Sites/SmartAdminAngularJS_4.x/seed-project/node_modules/_jsdom@9.12.0@jsdom/lib/jsdom/living'
@ ./~/_jsdom@9.12.0@jsdom/lib/jsdom/living/xmlhttprequest.js 4:18-42
@ ./~/_jsdom@9.12.0@jsdom/lib/jsdom/browser/Window.js
@ ./~/_jsdom@9.12.0@jsdom/lib/jsdom.js
@ ./~/_jQuery@1.7.4@jQuery/lib/node-jquery.js
@ ./~/_imports-loader@0.7.1@imports-loader?jQuery=jquery!./~/_jquery-color@1.0.0@jquery-color/jquery.color.js
@ ./src/lib.ts
@ ./src/main.ts
@ multi webpack-dev-server/client?http://localhost:4200 ./src/main.ts

How should I do?
Hi,

Please do not paste random codes or long error messages on this comments page. We have a separate dedicated email for that found in our profile page and in our documentation.

Solution to your issue: You downloaded the wrong version of jquery, please remove jquery color picker from dependency and rebuild from scratch. Please email us on support email if you have further issues.

Thanks,
Support
'rebuild from scratch' meaning, delete the directory, unpack and repeat the npm steps to install packages and build.
Thanks,I try it.
I try it on a new PC, but failed. jquery-color:1.0.0 github url is 404.
Hi,

Please read my instructions again and contact us via the support email. As I mentioned earlier, we do not provide support over comments page.

Instructions for how to ask for support:
https://wrapbootstrap.com/user/MyOrange
aelfred PURCHASED
Hello

Are you working in another solution for to the touchscreen problem for Smart Widgets/JarvisWidgets besides disabling the flag "chrome://flags/#touch-events"? I don't want to disable touchscreen for every site just for this.
Hi,

That's an issue with Chrome and Windows 10 Touch technology. This is beyond our control.

Thanks,
Support
I'm using a layout where the body has class "menu-on-top". One of my menu items has the text "Transactions", and it's slightly too long, so the word is cut short and the missing letters replaced with "...". I don't really like this. How can I adjust that so it shows the full word?
Hi,

Please read see our instructions here on how to request support: https://wrapbootstrap.com/user/MyOrange

Thanks,
Support
we are developing our software in laravel.

Do you have any larave package created for this?
Or can you help me if there is a way i can use this application to laravel.
Hello,

Whatever packages you see inside the zip folder is whats included. We do not have any other packages with us. Laravel isn't support out of the box, but if you know how, you should be able to convert the PHP version to laravel version.
Hello, I want to begin a new project using .Net Core 2.0, do you recommend me to wait for the update or I can begin with a previous version and the migrate ?

Thanks !!
hi,
im planing to buy this template i want to know is this temp cover my requirements

ES6
Webpack to build the css and js files using node
Bable as compiler (should be done with ES6)
Hello Guys I am Getting this Error VS CODE CORE 2

An error occurred during the compilation of a resource required to process this request. Please review the following specific error details and modify your source code appropriately.

/home/raven/RRHH/Views/Shared/_Layout.cshtml

The name 'TelemetryConfiguration' does not exist in the current context
-
<link href="~/css/style.css" rel="stylesheet" type="text/css" />
<link href="~/css/responsive.css" rel="stylesheet" type="text/css" />
<!-- CORE CSS TEMPLATE - END -->

</environment>

<!--@Html.ApplicationInsightsJavaScript(TelemetryConfiguration)-->
</head>
<body class="@ViewData["body_class"]">


@Html.Partial("_Topbar")
@Html.Partial("_Container")
'IHtmlHelper<dynamic>' does not contain a definition for 'ApplicationInsightsJavaScript' and no extension method 'ApplicationInsightsJavaScript' accepting a first argument of type 'IHtmlHelper<dynamic>' could be found (are you missing a using directive or an assembly reference?)
-
<link href="~/css/style.css" rel="stylesheet" type="text/css" />
<link href="~/css/responsive.css" rel="stylesheet" type="text/css" />
<!-- CORE CSS TEMPLATE - END -->

</environment>

<!--@Html.ApplicationInsightsJavaScript(TelemetryConfiguration)-->
</head>
<body class="@ViewData["body_class"]">


@Html.Partial("_Topbar")
@Html.Partial("_Container")
Sorry i Missed Some Views,

Now i Have this error

InvalidOperationException: No service for type 'Microsoft.ApplicationInsights.Extensibility.TelemetryConfiguration' has been registered.
Hi,

Please note that you need to contact us on support email for support related questions. Pasting random codes on comments page makes it look messy. We like to have this space clean and clear for pre-purchase related questions only.

Regarding core 2.0; we only provide support for core 1.0; Core 2.0 will be supported after we release version 2.0.

Thanks,
Support
Hello,

can you tell me something about your implementation of the Outlook View? Has it some function or is it just a template that we have to fill with live?

Thanks!
Hi,

No function. Only a template.

Thanks,
Support

Write a comment

This is a great way to give the seller feedback and ask them questions about their item.

You must sign in to write a comment

Sign in or sign up to make a purchase

$36
27677Purchases

Licenses: Details »

Single application $36
Version:1.9.0.1
Type:
  • HTML Template
Bootstrap: Compatible with 3.3.x
Layouts:
  • Responsive
  • Fluid
  • Fixed-width
Browsers:
  • IE 9, 10, 11
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
Uses Less:Yes
Uses Sass:Yes
Categories:
Tags: admin template, angular, angularjs, asp.net, lightweight admin, reactjs, responsive dashboard, webapp
Item#:WB0573SK0
Released:3 years ago
Updated:Yesterday
Sold exclusively on WrapBootstrap
MyOrange

MyOrange

Signed up 5 years ago

Need a front-end theme?

About Bootstrap

Bootstrap is designed to help people of all skill levels – designer or developer, huge nerd or early beginner. Use it as a complete kit or use it to start something more complex.

Unlike other front-end toolkits, Bootstrap was designed first and foremost as a styleguide to document not only its features, but best practices and living, coded examples.

Built to support new HTML5 elements and syntax with progressively enhanced components.

Browser support

Bootstrap is tested and supported in major modern browsers like Chrome, Firefox, and Internet Explorer.

Tested and supported in Chrome, Safari, Firefox, Internet Explorer, and Opera.
  • Latest Chrome
  • Latest Firefox
  • Latest Safari
  • Latest Edge
  • Internet Explorer 9/10/11
  • Latest Opera

Features & includes

Bootstrap provides an unparalleled array of features and reusable components that let you hit the ground running: